PfSense2.2 IPSEC EAP-TLS error 13843



  • Hello all.
    I am trying to create a scenario as mentioned in the subject. The client is a win8.1 laptop and I used the guide provided by https://doc.pfsense.org/index.php/IKEv2_with_EAP-TLS.
    I am constantly getting the error 13843 Invalid payload received.
    I also tried the MSChapv2 version using the corresponding guide https://doc.pfsense.org/index.php/IKEv2_with_EAP-MSCHAPv2, but I also get the same error.
    I recreated both the server and client (used only on EAP-TLS) certificates and recreated the whole project. The problem remains.
    Any ideas?
    Thank you very much

    EDIT: I forgot to mention that I am a pfSense newbie.



  • I'm by no means an expert either, so take what I say for what it's worth.

    I had a similar issue, using EAP-MSCHAPv2. In my case, I had to create the cert a very specific way.

    As the instructions state, I used my local host name for the common name. Then I had to add the external IP address as an IP type alternative name, and also as a DNS type.

    I get connected just fine now. Only issue I now is, internal DNS names don't resolve. I can only my network devices by IP.

    Hope this helps. Good Luck!


Log in to reply