2.2 upgrade - boot failure with ASUS M3A78-EM - and work-around



  • i just upgraded a system based on the ASUS M3A78-EM motherboard to pfsense 2.2 tonight, and it failed to boot, with the several error messages like this:

    run_interrupt_driven_hooks: still waiting after 60 seconds for xpt_config

    based on this, and similar advice that turned up in a web search, i was able to fix the problem, by disabling on-board 1394 in the BIOS (fortunately, i'm not using any 1394 devices).

    my system ran fine with pfsense 2.1.x; the problem only appeared after the 2.2 update.

    note that the error message i received was very slightly different from the one in the linked pfsense troubleshooting page (xpt_config vs. xpt_action), so users searching for the current error message may not find that page.



  • We had a similar problem with recent upgrade, same message. 
    We do not have fireware, tried disabling USB but no luck.
    After some research we came across this post: http://freebsd.1045724.n5.nabble.com/run-interrupt-driven-hooks-still-waiting-for-xpt-config-tp3925904p3925915.html
    that gave us the idea that some storage might not be responding to the pfsense kernel.
    Finally we figured out the problem, it was an faulty old CD/DVD Drive that no longer worked. Unplugging the drive solved our boot problem.