[SOLVED] SYN_SENT:CLOSED to IP Address I'm trying to connect to…



  • Hi Everyone!

    This is my first time working with PFSense so I hope I'm posting this in the right place. I'm basically trying to access an IP camera after installing a new PFSense router, and for some reason it is getting blocked.

    The address of the IP camera is set to a static internal IP address (0.80), and when I check the Diagnostic –> Show States for that IP it shows a loop of CLOSED:SYN_SENT, SYN_SENT:CLOSED.

    Do I need to add a NAT/ Firewall exception for IP camera access? I looked for similar questions on the board and the closest post I could find was https://forum.pfsense.org/index.php?topic=81495.0 (I tried everything in the linked post to the best of my ability, though the problem remains).

    Sorry if this is a bit ambiguous, I'm still new to advanced networking so I'm not sure what information I need to provide for successful troubleshooting.

    Thanks for any help! :)





  • Hi KOM,

    Thanks for the reply. I've been looking at those two links for about the last hour comparing them to what I've added, and I still can't see the problem.

    Specifics of NAT entry:

    Disabled: unchecked
    No RDR: unchecked
    Interface: WAN
    Protocol: TCP
    Source: (didn't go into advance tab)
    Destination: WAN address (the box below the dropdown is greyed out)
    Destination Port Range: from 88 to 88 (I THINK this is the correct port…it's what shows up at the end of the "show states" entry anyway
    Redirect target IP: 192.168.0.80 (address of IP camera)
    Redirect Target Port: 88 (same as above)
    Description: Security Camera
    No XMLRPC Sync: unchecked
    NAT relection: use system default
    Filter rule association: Rule NAT Security Camera

    So this shows up under the NAT section, and then under Firewall –> Rules a new entry is populated from the NAT entry.

    Anyone see a problem?



  • SYN_SENT:CLOSED means nothing is replying. The camera might be missing a default gateway or have the wrong gateway, or have a local firewall, or maybe not listening on port 88 at all.



  • Hi cmb,

    I definitely thought about the wrong port possibility. I've tried 2 other possible ports with no success, though I suppose that still could be it.

    As far as the gateway or firewall options…I'm not really sure. The camera worked just fine with the Ausus Router/ Tomato combination I had previously, and as far as I know there wasn't any kind of camera firewall I needed to configure for that setup.

    I'll try and take a look at the specific ZMODO setup and see if I can find a discrepancy there. Good to know that the NAT entry looked correct (with the possible exception of an incorrect port).



  • Got it!

    Wow, well you were right on money cmb, the gateway and IP had changed when we switched over to PFsense. Got the right info into the NAT entry and we were off and running.

    Thanks KOM and cmb, I really appreciate the help! :)


Log in to reply