Duvida Cachemgr.cgi no Pfsense2.2



  • Boa tarde pessoal, estou com o pfsense 2.2 todo configurado com squid 2.7 e squidguard, porem ao tentar acessar o cachemgr.cgi recebo o erro "500 - Internal Server Error", segui varias dicas que encontrei no forum do pfsense mas nenhum consegui fazer funcionar, em todos da o erro 500, o log do lighthttpd n aparece nada pra me ajudar.

    Já fiz o link do .cgi pro /usr/local/www, ja configurei o cachemgr.conf, o squid ta configurado tb… ate tentei a dica onde acrescentamos umas linhas no squid.xml para adicinar uma "TAB" no proxy server, mas tb n consegui.

    Alguem conseguiu fazer funcionar o acesso pro cachemgr.cgi com o pfsense 2.2?

    Abraço



  • Boa tarde pessoal,

    Conseguir aqui fazer funcionar com o squid 2.7 no pfsense 2.2, caso alguem tenha esse mesmo problema de erro 500, basta pegar o cachemgr.cgi do squid3 do pfsense, fazer uma copia e jogar no diretorio correto do squid 2.7, fazer o link simbolico para o /usr/local/www, colocar a regra la no custom options "cachemgr_passwd none all" para ter acesso sem senha ao cachemgr, configurar o cachemgr.conf com localhost e a porta utilizada pelo squid e adicionar no squid.inc o parametro "http_port localhost:8080" logo abaixo da linha que contem o outro http_port, ficando assim:
    $conf .= "http_port {$real_ifaces[$i][0]}:$port\n";
    $conf .= "http_port localhost:8080\n"

    Basta reiniciar o squid e acessar via browser http://ip-pfsense/cachemgr.cgi e preencher os dados.

    Tudo que tem aqui achei nos tutoriais do forum, o unico detalhe que não encontrei nos turoriais e pelo forum e que muita gente esbarra é justamente a adição da linha "http_port localhost:8080", pois sem essa linha quando vai acessar da o erro de time out, tanto com squid 2.7 ou squid3, por tanto para ter acesso tem que ter esse parametro para funcionar.

    tambem pode ser adicionado uma aba no serviço do proxy para abrir diretamente o cachemgr sem ter que preencher nada, basta seguir o tutorial que tem no forum.

    Espero ter sido claro, qualquer duvida so falar.

    Abraços


Log in to reply