You have less interfaces than number of connections!



  • We upgraded to 2.2 and had traffic shapers enabled.

    We removed the shapers to clen them up and when trying to re-add them we get the error

    "You have less interfaces than number of connections!"

    Our pfSense is on VMware with E1000 nics.

    Anyone have this issue?



  • https://forum.pfsense.org/index.php?topic=33026.0

    You probably already saw this old suggestion from long ago but I thought I'd link to it anyway.



  • Saw it but didn't help i'm afraid.



  • @craggy:

    We upgraded to 2.2 and had traffic shapers enabled.

    We removed the shapers to clen them up and when trying to re-add them we get the error

    "You have less interfaces than number of connections!"

    Our pfSense is on VMware with E1000 nics.

    Anyone have this issue?

    Yep. No solution found yet
    https://forum.pfsense.org/index.php?topic=88572.msg489506#msg489506



  • I was having the same issue with 1 WAN and 3 LANs. After the upgrade to 2.2-RELEASE I could not connect to any websites. Narrowed it down to the Traffic Shaper. Removed the shaper and web flowed smooth again. Tried to add the shaper back but would only let me use the wizard with 1 WAN and 2 LANs.

    After some head scratching and failed troubleshooting I disabled the 3rd LAN and applied. Then re-enabled the 3rd LAN and applied. The traffic shaper wizard now recognized all 3 LANS.

    Maybe worth a try.



  • any luck with this in the end?  I have the same issue trying to setup traffic shaper where it can't see any of my NIC's in the wizard or in the actual queue config screens

    I suspect it maybe due to the virtualised xn drivers as I am running in XenServer and the OP is running in VMware.

    EDIT: nevermind - found this bug tracker confirming that ALTQ is not currently working with xn PV drivers
    https://redmine.pfsense.org/issues/4401#note-10



  • With the same error: "You have less interfaces than number of connections!"

    Running on release 2.2.5 the same issue with more than 2 active interfaces.

    Could not test in production, but this is what i done:

    • Disable all LAN interfaces and stay with one WAN and one LAN interface.
    • Execute the Traffic shaper wizard and complete it.
    • Check your Status - Queues  (menu status)
    • Check your Shaper and bandwidths.
    • Enable other LAN interfaces.
    • Enable Queue on each interface ( Enable/disable discipline and its children )
    • Goto the Traffic Shaper - By Queues tab  (https://…../firewall_shaper_queues.php)
    • Choice the qLink queue and for each interface do the:  Clone shaper/queue on this interface  action
    • Choice the qInternet queue and for each interface do: Clone shaper/queue on this interface  action
      ---- this will copy also all sub-queues behind qInternet.
    • Remove qDefault from LAN interfaces (qLink is the default).
    • Check the queues tab to see if the queues are created.
    • Check the Queue status (  https://..../status_queues.php )  if all queues are active
    • Adjust values of all qLink queues to match internet upload speed (the sum of all queues is your speed).

    Remark:  this wil limit the bandwidth between the LAN segments also because the queues are generic, the Traffic shaper wizard only assumes traffic to/from WAN-LAN's  and not traffic between LANs!  If you want this you need to manual create Queue's or adjust the floating queue rules to be more specific.


Log in to reply