Install to Kingston 2gb SD on Darkwire SD-IDE convertor



  • I'm running an old Optima mini-tower with a Celeron 600mhz CPU. With the 1.2-RELEASE Live CD install to my 10gb IDE hard drive everything is working fine, but I've now bought a standard Kingston 2gb SD card and Darkwire SD-IDE convertor, and while the BIOS and boot sequence seem to detect everything fine, as well as appearing when I drop to a shell and run```
    fdisk /dev/ad0

    
    I chose option 99 (full install) from the menu, it sees that I have ad0 as a device, it allows me to create a partition taking up the whole ad0 disk and format it as a FreeBSD slice which completes successfully, but I then receive an error saying no partitions are available for installation.
    
    Anybody have any ideas?


  • Make sure your sdcard has the write lock not set.



  • Didn't work. Switched SD card to opposite signal (there are no markings for write/read-only). Card was still detected in BIOS and by FreeBSD during bootup as ad0, the partitioning still supplied a success message, but it still said no partitions were available when trying to progress to the actual installation.



  • U must fill 0x00 to first 63 sector to delete MBR  and  Boot Sector
    I have to use this method with thumbdrive to boot WINPE with NTFS File System  :)



  • OK I'll give that a go. Thanks



  • Backup the MBR of your CF card first. ;)
    It's possible to make a card unusuable this way

    @http://pcengines.ch/freedos.htm:

    Caveats: Make a backup of the blank CF card with dd if you want to reuse it - repartitioning CF cards is tricky. SNIP



  • The SD card itself was only AU$15, if I have to buy another one I don't mind writing it off as a learning experience. If I break the SD-IDE convertor however, I'll be a little more annoyed..

    About to try it now so hoping all goes well.



  • OK, I ran:

    dd if=/dev/zero of=/dev/ad0 bs=512 count=100
    

    which returned 51200 blocks written. All appears well.

    Went to try the install again. It sees AD0 as a disk, it lets me format and create the partition, but again when I'm supposed to choose the partition, it says no partitions are available :(

    edit
    I've now tried switching the read/write switch up/down and re-running the dd command. Seems like it just can't zero anything out on the drive.

    I tried running "fdisk -B ad0" and "fdisk -I ad0", but they both report: fdisk: Geom not found: "ad0"



  • Tried a different brand SD card tonight and it has the same problem. I noticed that just dropping to a shell and running fdisk /dev/ad0 on the second SD card showed that it also apparently had a FreeBSD slice using the entire disk, yet I hadn't performed any installation procedure at the time. I'm now thinking maybe the adapter is causing the problem, not the cards.

    I'm now waiting on arrival of a USB SD reader to confirm that neither card was ever actually modified.

    edit
    I've now tried 2 different SD cards in 3 different boxes (combination of old and new tech from both AMD and Intel) trying to install PFSense 1.2, Ubuntu 7.10 and Windows XP, and all have the same problem. This leads me to believe it's the adapter card that is causing the problem.

    I've contacted Darkwire support for some further assistance.



  • Problem ended up being a faulty adapter card. Supplier sent me a replacement card and all is well.


Log in to reply