Pfsense + Wifi AP= Wifi only working if wired PC is turned on



  • Hi guys

    Some days ago I set up my very first pfsense. My pfsense is running on a APU Board. My network is set up as shown below:

    WAN – Modem -- pfsense -- Switch (Netgear) -- Asus Wifi AP

    There are also some wired connections to the switch (e.g. my PC). With the wired clients everything works fine, I have a 250mbps connection to the wan with these clients.

    But my wifi doesn't work. And now here comes the strange part (I am computer scientist and I've never seen something like this before). The Asus AP does only have connection to the pfsense if my wired PC is turned on. When I shut down my PC, the wifi won't work anymore.

    Switch is connected to the lan port of my pfsense. The lan interface is 192.168.1.200. The AP is connected to the switch. On the AP, I plugged the cable into the LAN Port. AP gets his LAN-Settings via DHCP (is all in same subnet). My DHCP is handled by pfsense, at Asus AP the DHCP Server is disabled.

    I can see my Wifi and I am able to connect to it with my laptop. But the AP does not find the way to the pfsense. There are a lot of ARP Request outgoing from my Notebook (who has 192.168.1.200? tell 192.168.1.18) but there is no answer.

    If I boot up my wired PC, my laptop gets immediatly a response (192.168.1.200 is at xx:xx:xx:xx:xx:xx). From now on my Wifi works well, I get 200mbps via 5ghz.

    But if I turn off my wired pc, after 1-2 minutes my wifi wont work anymore and all wifi clients are sending ARP Request again with "who as ...1.200" .

    So my Wifi AP can only connect to the pfsense if my wired pc is turned on.

    Does anyone have any guesses? I really don't know what to do, I've never had such a problem before..

    thanks in advance

    ps: please excuse my english



  • I'm not familiar with the Negtear switch or the Asus AP, but I think it sounds a little odd that your AP is picking up it's IP via DHCP. In most cases you should set the IP on an access point statically, at least in my experience. Have a go at assigning a permanent IP to the Asus AP and see if that has any effect.


Log in to reply