Apache with mod_security-dev 2.4.9_2pkg v0.43 on pfense 2.2



  • I've been trying to get Apache with mod_security-dev 2.4.9_2pkg v0.43 working on the new PfSense 2.2. But I keep getting this error

    Mar 6 12:19:13	php-fpm[88293]: /pkg_edit.php: apache_mod_security_package: configuration resync is starting.
    Mar 6 12:19:13	php-fpm[88293]: /pkg_edit.php: The command '/usr/pbi/proxy_mod_security-amd64/sbin/httpd -t' returned exit code '1', the output was 'AH00526: Syntax error on line 538 of /usr/local/etc/apache24/httpd.conf: ModSecurity: No action id present within the rule'
    Mar 6 12:19:13	php-fpm[88293]: /pkg_edit.php: apache_mod_security_package: There was an error parsing the Apache configuration: 1
    Mar 6 12:19:13	php-fpm[88293]: /pkg_edit.php: apache_mod_security_package: configuration resync is ending.
    

    which results in "Internal Server Error"

    httpd log from Apache:

    
    /var/log/httpd-error.log
    
    DateTime	Severity	Message
    Fri Mar 06 12:57:48.419606 2015	proxy:warn	[pid 8772:tid 34403160064] [client 173.245.xxx.xxx:43264] AH01144: No protocol handler was valid for the URL /contact.aspx. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
    

    I was wondering if anyone knows how to fix this?

    PS: I noticed that no rules were to be found on the rules page…

    Thanks

    /cbadk



  • I actually have a similar issue with version proxy_mod_security-2.4.9_4

    At this moment the install seems to hang.
    I've retried several times to "reinstall" / "remove + install" etc. but there is no menu item appearing in the Services menu.

    Could the fact that I have Varnish 3 running be an issue in here?




  • Had the same issue and this worked for me:

    Make sure the Backend Path path contains a slash and isnt empty in the Location(s) tab.

    And in apache conf, it looks like the below in /usr/pbi/proxy_mod_security-amd64/local/etc/apache24/Includes/virtualhosts.conf.
    This didnt work:

    ProxyPass        balancer://mysite
      ProxyPassReverse balancer://mysite

    This did:

    ProxyPass        balancer://mysite/
      ProxyPassReverse balancer://mysite/


Log in to reply