Sarg não gera relatório "view Report"



  • Oi gente, uso o squid + squidguard instalei o Sarg para gerar os relatórios, mais não esta gerando. no promt de comando do pfsnse eu dou o comando "sarg" ou "sarg -x" ele carrega normalmente, no entanto não gerar os arquivos em /usr/local/sarg-reports como você pode vê abaixo.

    [2.2-RELEASE][admin@firewall.supergiro.com]/root: sarg
    SARG: Records in file: 6124783, reading: 100.00%

    Testando na maquina virtual ele faz todo o processo e gera os arquivos em  /usr/local/sarg-reports como pode vê abaixo.

    [2.2-RELEASE][admin@firewall.supergiro.com]/root: sarg
    SARG: Records in file: 6124783, reading: 100.00%

    SARG: Successful report generated on /usr/local/sarg-reports/2015Mar01-2015Mar08

    Desde já obrigado pela ajuda!



  • Estou tendo o mesmo problema. Instalei o pacote do squid 2 e o sarg no pfsense 2.2.1:

    [2.2.1-RELEASE][root@pfSense.localdomain]/root: sarg -x
    SARG: Init
    SARG: Loading configuration from /usr/local/etc/sarg/sarg.conf
    SARG: Chaining IP resolving module "dns"
    SARG: Loading exclude host file from: /usr/pbi/sarg-amd64/etc/sarg/exclude_hosts.conf
    SARG: Loading exclude file from: /usr/pbi/sarg-amd64/etc/sarg/exclude_users.conf
    SARG: Reading host alias file "/usr/pbi/sarg-amd64/etc/sarg/hostalias"
    SARG: List of host names to alias:
    SARG: Parameters:
    SARG:          Hostname or IP address (-a) =
    SARG:                    Useragent log (-b) =
    SARG:                    Exclude file (-c) = /usr/pbi/sarg-amd64/etc/sarg/exclude_hosts.conf
    SARG:                  Date from-until (-d) =
    SARG:    Email address to send reports (-e) =
    SARG:                      Config file (-f) = /usr/local/etc/sarg/sarg.conf
    SARG:                      Date format (-g) = Europe (dd/mm/yyyy)
    SARG:                        IP report (-i) = No
    SARG:            Keep temporary files (-k) = No
    SARG:                        Input log (-l) = /var/squid/logs/access.log
    SARG:              Resolve IP Address (-n) = Yes
    SARG:                      Output dir (-o) = /usr/local/sarg-reports/
    SARG: Use Ip Address instead of userid (-p) = No
    SARG:                    Accessed site (-s) =
    SARG:                            Time (-t) =
    SARG:                            User (-u) =
    SARG:                    Temporary dir (-w) = /tmp/sarg
    SARG:                  Debug messages (-x) = Yes
    SARG:                Process messages (-z) = No
    SARG:  Previous reports to keep (–lastlog) = 0
    SARG:
    SARG: sarg version: 2.3.9 Sep-21-2014
    SARG: Reading access log file: /var/squid/logs/access.log
    SARG: Records in file: 119, reading: 100.00%
    SARG:    Records read: 119, written: 119, excluded: 0
    SARG: Squid log format
    SARG: Period: 01 Apr 2015
    SARG: Sorting log /tmp/sarg/192_168_1_100.user_unsort
    SARG: Making index.html
    SARG: Successful report generated on /usr/local/sarg-reports/01Apr2015-01Apr2015
    SARG: End

    [2.2.1-RELEASE][root@pfSense.localdomain]/root: ls -la /usr/local/sarg-reports/
    total 8
    drwxr-xr-x  2 root  wheel  512 Apr  1 13:04 .
    drwxr-xr-x  16 root  wheel  512 Apr  1 13:04 ..

    Quando tento ver o relatório:

    Error: Could not find report index file.
    Check and save sarg settings and try to force sarg schedule.



  • Verifica se não está sendo gerado neste diretório /usr/pbi/sarg-amd64/local/sarg-reports.



  • @IrvingGo:

    Verifica se não está sendo gerado neste diretório /usr/pbi/sarg-amd64/local/sarg-reports.

    Bom dia a todos,

    Estou com o mesmo problema, depois que atualizei pra 2.2 ficou assim !

    Na pasta ele está gerando os relatórios, mas na interface não aparece, já reinstalei e nada. =/



  • Como o IrvingGo disse, tem um bug.
    Ele está salvando na pasta /usr/pbi/sarg-amd64/local/sarg-reports/.
    Criem um link: ln -s /usr/pbi/sarg-amd64/local/sarg-reports/ /usr/local/sarg-reports/



  • Exatamente isso!
    Fazendo:

    [2.2.1-RELEASE][root@pfSense.localdomain]/root: rm -rf /usr/local/sarg-reports
    [2.2.1-RELEASE][root@pfSense.localdomain]/root: ln -sf /usr/pbi/sarg-amd64/local/sarg-reports /usr/local/sarg-reports

    Já resolve o problema. Mas é bom corrigir no pacote.



  • Pessoal, obrigado pela correção, um mero symlink pra resolver um probleminha  :P

    Funcionou perfeitamente aqui.



  • @mgondim:

    Exatamente isso!
    Fazendo:

    [2.2.1-RELEASE][root@pfSense.localdomain]/root: rm -rf /usr/local/sarg-reports
    [2.2.1-RELEASE][root@pfSense.localdomain]/root: ln -sf /usr/pbi/sarg-amd64/local/sarg-reports /usr/local/sarg-reports

    Já resolve o problema. Mas é bom corrigir no pacote.

    Resolvido! Obrigado pela dica, mas seria legal corrigir o problema.



  • Legal, estava com o mesmo problema na versão Pfsense 2.2.4, squid 4.3.10, sarg 0.6.6, e funcionou perfeitamente, vlw.


Log in to reply