Using pfSense with Sky ADSL



  • Hi all,

    I've worked my way through this rather old thread here: https://forum.pfsense.org/index.php?topic=48663.60 to try to wave goodbye to my shiny new Sky Router (http://res.cloudinary.com/hugoaoilw/image/upload/yovg3ywcdsmzqpkgyacf) and replace it with my newly built pfSense box.

    So, I'm using a Draytek Vigor 120 modem and the settings as shown in the attachment named "Internet_Access". The other attachment named "Online_Status" shows that the modem has made the connection to Sky.

    I've used wireshark to extract my Client Identifier that is sent by the Sky router as option 61 in the DHCP request to Sky. I am using this string separated by a | in the "Hostname" section of DHCP configuration for the WAN connection in pfSense.

    For some reason (that being something I'm doing wrong), it's not working. I've tried as much as I can think of but I've hit a bit of a wall so if anyone has any suggestions or has successfully managed to get the same setup working, I'd love to hear from you!

    Thanks,

    Cal.






  • Hello,

    Did you ever get this working. I'm trying to get the same set up at the moment and I'm hitting the same problem.

    Thanks
    Fred


  • Netgate Administrator

    Sky were using MPoA/DHCP at one point rather than PPPoA. I'm not sure what they are using currently (or whether they use more than one thing).
    Can you see what settings the Sky Modem/Router is using?

    Steve



  • Hi Fred,

    If I remember correctly, the issue was that the instructions were for a Sky fiber connection, not ADSL. The solution is to set pfSense up to connect using PPoE, then enter the username and password you sniffed using Wireshark in the corresponding boxes.
    This being said, within the last 3 weeks, something changed at Sky so that using a Draytek 120 modem only allowed me 5mbps down. I tried with another spare 120 and got the same result. The issue was fixed by buying and using a Draytek 130. About £80 from Amazon. Bit pricey but well worth it IMO. No more Sky broadband offering my wireless to complete unknowns.

    Let me know if you need anymore help.

    Cheers,

    Cal.



  • Slightly off topic…

    A lot of ISP bundled wireless routers are happy to continue working on ADSL only with their wireless antenna circuit severed or the antenna jack desoldered from the PCB. Just check first that the bundled router is your property and not simply on loan before modifying it. I have had an ISP demand that their 3-year old kit was sent back to them when I moved house.

    Alternatively, lead flashing as used in building roof construction can be used to fashion a screening container. An old biscuit tin (with lid) may be just as effective for signal containment. Use rubber grommets or proper cable glands for the wiring through the tin.

    If the antenna is removable, that might just be enough attenuation to stop anyone outside your building using the wireless. If not, perhaps a foil 'condom' for the antenna would work. I've not tried this, I just thought of it now.

    If the bundled wireless router doesn't channel hop, setup an old wireless router with the same channel and SSID and configure it with a higher transmit power if you can. Leave it powered up without Ethernet and ADSL connections so that it becomes a black hole network. Make sure you have your own separate secure wireless on another channel.



  • Hi Guys,

    Thanks for replying. I haven't actually checked this thread until now as I've ha a lot of other things going on. Sky have supplied me with a SR102 and when I log in it says it is using PPPoA.

    Callahan - Do you mind sharing the settings (obviously not your broadband user name / pass) you used on your Draytek 120 / 130 and your pfSense box so I can see if I can get this working? I can get my 120 to sync up but I can't get a connection.

    Thanks
    Fred


  • Netgate Administrator

    I used a V120 for a long time, though not with Sky but it was using standard PPPoA connection in the UK.
    What do you see in the PPP logs? Is pfSense attempting a PPPoE connection?
    You usually have to make some special arrangement to connect to the V120 webgui from behind pfSense. Since you can see it is synced I assume you have done that? If not and you are able to connect to it you might have something wrong!
    See: https://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall

    Steve