Got 3g card stuck in initial loop



  • I have a Ericsson H5321gw witch is stuck in a initial loop
    I had a Ericsson H5321w that did not have anyproblem.

    The w card did use u3g and the gw is using umodem.

    PPP log

    Mar 10 08:35:50 uhome ppp: [opt1_link0] CHAT: Detected Hayes compatible modem.
    Mar 10 08:35:51 uhome ppp: [opt1_link0] CHAT: Dialing server at 99#…
    Mar 10 08:35:51 uhome ppp: [opt1_link0] CHAT: ATDT
    99#
    Mar 10 08:35:52 uhome ppp: [opt1_link0] CHAT: Connected at an unknown speed.
    Mar 10 08:35:52 uhome ppp: [opt1_link0] MODEM: chat script succeeded
    Mar 10 08:35:52 uhome ppp: [opt1_link0] Link: UP event
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: Up event
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: state change Starting –> Req-Sent
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: SendConfigReq #49
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACCMAP 0x000a0000
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MRU 1500
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MAGICNUM 0bd108b0
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: rec'd Configure Request #2 (Req-Sent)
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  AUTHPROTO CHAP MD5
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACFCOMP
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  PROTOCOMP
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MRU 1500
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACCMAP 0x00000000
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MAGICNUM dea31454
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: SendConfigRej #2
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACFCOMP
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  PROTOCOMP
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: rec'd Configure Ack #49 (Req-Sent)
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACCMAP 0x000a0000
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MRU 1500
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MAGICNUM 0bd108b0
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: state change Req-Sent –> Ack-Rcvd
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: rec'd Configure Request #3 (Ack-Rcvd)
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  AUTHPROTO CHAP MD5
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MRU 1500
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACCMAP 0x00000000
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MAGICNUM dea31454
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: SendConfigAck #3
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  AUTHPROTO CHAP MD5
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MRU 1500
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  ACCMAP 0x00000000
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MAGICNUM dea31454
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: state change Ack-Rcvd –> Opened
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: auth: peer wants CHAP, I want nothing
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: LayerUp
    Mar 10 08:35:52 uhome ppp: [opt1_link0] CHAP: rec'd CHALLENGE #0 len: 74
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  Name: "Kermit"
    Mar 10 08:35:52 uhome ppp: [opt1_link0] CHAP: Using authname "user"
    Mar 10 08:35:52 uhome ppp: [opt1_link0] CHAP: sending RESPONSE #0 len: 25
    Mar 10 08:35:52 uhome ppp: [opt1_link0] CHAP: rec'd SUCCESS #0 len: 20
    Mar 10 08:35:52 uhome ppp: [opt1_link0]  MESG: Congratulations!
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: authorization successful
    Mar 10 08:35:52 uhome ppp: [opt1_link0] Link: Matched action 'bundle "opt1" ""'
    Mar 10 08:35:52 uhome ppp: [opt1_link0] Link: Join bundle "opt1"
    Mar 10 08:35:52 uhome ppp: [opt1] Bundle: Status update: up 1 link, total bandwidth 28800 bps
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: Open event
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: state change Initial –> Starting
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: LayerStart
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: Open event
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: state change Initial –> Starting
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: LayerStart
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: Up event
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: state change Starting –> Req-Sent
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: SendConfigReq #49
    Mar 10 08:35:52 uhome ppp: [opt1]  IPADDR 0.0.0.0
    Mar 10 08:35:52 uhome ppp: [opt1]  PRIDNS 0.0.0.0
    Mar 10 08:35:52 uhome ppp: [opt1]  SECDNS 0.0.0.0
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: Up event
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: state change Starting –> Req-Sent
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: SendConfigReq #153
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: rec'd Protocol Reject #1 (Opened)
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: protocol IPV6CP was rejected
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: protocol was rejected by peer
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: state change Req-Sent –> Stopped
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: LayerFinish
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: rec'd Terminate Request #1 (Opened)
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: state change Opened –> Stopping
    Mar 10 08:35:52 uhome ppp: [opt1_link0] Link: Leave bundle "opt1"
    Mar 10 08:35:52 uhome ppp: [opt1] Bundle: Status update: up 0 links, total bandwidth 9600 bps
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: Close event
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: state change Req-Sent –> Closing
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: SendTerminateReq #50
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: Close event
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: state change Stopped –> Closed
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: Down event
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: LayerFinish
    Mar 10 08:35:52 uhome ppp: [opt1] Bundle: No NCPs left. Closing links…
    Mar 10 08:35:52 uhome ppp: [opt1] IPCP: state change Closing –> Initial
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: Down event
    Mar 10 08:35:52 uhome ppp: [opt1] IPV6CP: state change Closed –> Initial
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: SendTerminateAck #50
    Mar 10 08:35:52 uhome ppp: [opt1_link0] LCP: LayerDown
    Mar 10 08:35:54 uhome ppp: [opt1_link0] LCP: state change Stopping –> Stopped
    Mar 10 08:35:54 uhome ppp: [opt1_link0] LCP: LayerFinish
    Mar 10 08:35:54 uhome ppp: [opt1_link0] Link: DOWN event
    Mar 10 08:35:54 uhome ppp: [opt1_link0] LCP: Down event
    Mar 10 08:35:54 uhome ppp: [opt1_link0] LCP: state change Stopped –> Starting
    Mar 10 08:35:54 uhome ppp: [opt1_link0] LCP: LayerStart
    Mar 10 08:35:54 uhome ppp: [opt1_link0] Link: reconnection attempt 1 in 3 seconds



  • Same here. Any new information about that?



  • Solved for me.
    I have an Apu board with an Dell DW5550 (or Ericsson F5521gw, which is the same hardware)
    I use port /dev/cuaU2
    and set Init String to "+CFUN=1" doese the trick for me.



  • Mine is in CDC ethernet mode with an UE0 interface.. I will try your tip to see.

    I think module worked fine in pfsense before..




  • Yes my card was also shown up as UE0 interface. But unte PPP Connections i have to chose /dev/cuaU2



  • I guess i gave up early on my UE0 devices. So it works fine as cuaU2. I may have to re-test some other modules now. Thanks for the heads up. Did require the +cfun=1 tip. I wonder if i could get my Novatel E371 going that way. It is LTE so i will try that next. It shows ue0 now.
    Thanks
    Signing off from my H5321gw



Log in to reply