X750e can i use udma



  • Hi. I have been reading for weeks on and off and have managed to install 2.1.5 on my firebox x750e and get almost everything working as I want it, with help from this forum, thanks for that.
    The one thing that is bugging me is that I wanted to use squid to cache so I have installed on a HDD but I noticed its running in pio4 because of the cf card needed to boot. I am now on bios b8 and have tryed to find a way of setting the cf to pio and the HDD to udma in any way possible but I'm at my wits end, can anyone help or is it not possible.
    Thanks Jay…


  • Netgate Administrator

    You should use 8.1 because it allows you to turn on ACPI and the good things that come with it.
    In 2.2 you can disable DMA per channel so you can have exactly that setup. See:
    https://forum.pfsense.org/index.php?topic=67823.msg479902#msg479902

    Steve

    Edit: Typo.



  • Thanks for that stephenw10 I was hoping you would reply I have read a lot of your posts and got your bios, I will try to do the upgrade to 2.2 which was what I had planned to try as I had tried 2.2 first but had trouble with the LCD and something else that slips my mind. I have done the mods to get the LCD and other things working so will these be carried over or have the problems been fixed in 2.2.
    Thanks..



  • Ok I tryed to update and it failed with the same error as this
    https://forum.pfsense.org/index.php?topic=87542.0
    I have tryed changing the bios settings and tried with and without the cf card. The thread mentions changing the power settings but i am running the B8 bios which seems to have had them removed? or am i just being stupid.
    Help appreciated thanks Jay..

    @stephenw10 in your above post u mention 8.1 which i took to be the freebsd under pfsense but do you mean the bios and if so where can i find it.
    Thanks Jay..

    Have found your 8.1 bios just going to flash it…well maybe not its 12.30 here will try after work tomorow and see how it goes


  • Netgate Administrator

    So, yes, there are a few ways around that error.
    Enable ACPI. That sets the value of smbios.system.product to something other than null. You need the 8.1 bios because I forgot to enable the menu in 8.0.  ::)
    Interrupt the boot loader and manually set that to something:

    set smbios.system.product="firebox"
    boot
    

    Wait for 2.2.1, or use a snapshot, because it's fixed there: https://redmine.pfsense.org/issues/4363

    Steve



  • ok so i couldn't wait so i've got it working now but the lcd is stuck on the client srvr screen and i cant for the life of me find the related threads that i know i've read on this subject is there a fix or am i imagining it (it is 1.20 here i've been at this since tea time)
    Also the 8.1 bios fixed it no probs but i'll add the line you suggested for good measure.
    Thanks Jay…


  • Netgate Administrator

    No need to add that line if you've enabled ACPI. It's pointless having extra loader variables that aren't needed.

    How are you starting lcdproc?
    When you are seeing the output from the daemon with no client it's either because the start process has gone wrong or the client can't talk to the daemon. If you have IPv6 enabled then the client could be running but is trying (and failing) to use IPv6 localhost to talk to the daemon. I don't know why that happens but there's an easy fix. If you're using the lcdproc-dev package and starting it via the menus it often fails to start correctly. There's a workaround for that linked from the Watchguard doc page.

    Steve



  • It should be started with a shell cmd as I had got it working by following the posted fixes on 2.1.5 so will all those patches etc still be effective or do I need to clear out and start again. I had lcdproc and lcdproc dev on 215 as recommended somewhere but after the install only the dev package was reinstalled so I installed the standard package but it was no help I'm going to see if I can find the fix you mention in the docs and get back in a while.
    Thanks Jay…

    P.S. no ip6


Log in to reply