ITunes Streaming Not Working after making some changes



  • I recently made a few changes to my pfSense and something seems to have broken iTunes streaming music.

    I enabled Snort and pfBlockerNG and added some new firewall rules as well as added a new ethernet card (OPT1 interface) and switched from Automatic outbound NAT rule generation to Manual outbound NAT rule generation.

    Everything seems to be working fine except for streaming music from iTunes (iTunes Match and iTunes Radio). I've tested with a few different iOS devices and iTunes on a Mac on both my LAN interface and OPT1 interface, both exhibit the same behavior: Song title displays, then quickly switches to another song, repeat, etc. If left long enough a song might start playing, but if you skip or the song ends it cycles through songs again without playing. If I take my iPhone off of wifi I am able to stream on LTE so I know it isn't a problem with the phone.

    I am not getting any alerts in Snort or any firewall logs related to this. I went ahead and disabled Snort, pfBlocker and the new firewall rules I made and continued to experience the same problem.

    I tried switching back to automatic outbound NAT but that didn't fix the problem either. Short of removing the OPT1 interface I think I have undone all of the changes I made but it still isn't working. Prior to this I had been running pfSense for quite a while with no problems and iTunes streaming worked.

    Any ideas what could be going on or where else to look?



  • Apple had a variety of issues last night/this morning. It's possible that some routes to their network may have been affected, explaining why it works one way but not another.

    They've fixed up all of the issues as of a couple hours ago, so if you're still experiencing problems, it's not an Apple issue. But if your problems are all resolved now, it was likely related to the issues Apple had.



  • I have narrowed my problem down to DNS on my pfSense.

    My pfSense is configured to use my ISPs DNS (via DHCP). If I let my devices use the pfSense for DNS iTunes streaming does not work. If I manually switch DNS on my client devices to either my ISPs DNS or Google DNS streaming works fine. Switching back to use my pfSense as the DNS server for the client devices and streaming stops working again.

    I think this problem began when I updated to 2.2 Any idea of what logs I can check to determine what is going on?



  • Hum, first idea would have been wireless dropouts. I get similar when streaming from Mini/MBP to ATV but always put it down to wireless. The iMac isn't going into power save on the screen/computer is it and cutting off the airplay ? Does it work if you just extend the screen onto the ATV (so mirroring in OS X) then drag iTunes onto the TV and maximise ? If that works with no dropouts then it would suggest a specific iTunes/Mabericks AirPlay issue. I assume it works fine with iPhone/iPad ?


  • Banned

    This post is deleted!

Log in to reply