SARG Redirector Report sem alguns dados nas primeiras linhas



  • Opa, e aí pessoal!!

    TO com um problema no Sarg que quando entro no redirector report, as primeiras linhas (muitas) aparecem sem o usuário, ip/name e accessed site. As únicas informações que aparecem é a data/horário e a rule.
    Depois de várias linhas aí sim começam a vir as informações completas separadas por usuário.
    Olhando os logs, percebi que essas linhas vazias são pq o destino não tem http:// na frente, ou é um ip direto ou login.microsoft ou www.algumsite.com.

    Alguém tem alguma luz pra ajudar???

    Já tentei reinstalar e continua com os mesmos problemas…

    Valeu!!



  • Alguém? Alguma luz? Algum bom samaritano que já tenha passado por isso a fim de ajudar uma pobre alma!??? ;)



  • Estou com o mesmo problema.

    Durante 1 dia de relatório, as primeiras 300 linhas do relatório do Redirector ficam com os campos USER ID, IP NAME e ACCESSED SITE em branco. Só aparecem preenchidos os campos DATE, TIME e RULE .

    Os demais ficam com todos os campos preenchidos.

    Pelo que verifiquei no blocked.log, pode ser coincidência, mas são registros que não começam com http.

    Alguém pode ajudar?

    SOFTWARE LIVRE sempre!!!



  • Andei olhando melhor e acontece com todas as requisições ssl (connect redirect)…



  • Bom,

    Entrei em contato com o cara do Sarg e isso acontece pelo formato padrão do redirector_log_format, que espera uma / antes da URL e uma / no final, mas no método CONNECT não tem as barras.

    Solução:
    Basta editar o sarg.conf e apagar a linha do redirector_log_format e colocar

    redirector_log_format #year#-#mon#-#day# #hour# #tmp#/#list#/#tmp# #url# #ip#/#tmp# #user# #end#
    

    Ou melhor ainda, comentar a linha, uma vez que o parse interno é mais rápido!

    O dev do sarg vai corrigir isso na próxima versão (2.3.10).
    PS.: O dev tá precisando de tradutores, não custa nada ajudar, então quem souber outra lingua, dá um toque!!  ;D


Log in to reply