Throughput horrible



  • Hi.  I've been running pfSense on an old Dell PowerEdge 350 for a long time and it has been great.  I recently upgraded my internet from 100 to 150 Mbps so I had to upgrade the firewall - the PE350 had 10/100 cards.  I decided rather than just throw in a new card I bought a Proliant DL380 G5.  Dual 2.33ghz Xeons, 6 GB RAM, 50 GB HDD, dual onboard Intel Pro 1000 gig NICs.  Yes, I know it's overkill but it was dirt cheap.

    Anyway, I install it and migrate pfSense over.  Everything is fine.  That was about almost a month ago.  Lately I'm seeing 9 Mbps throughput.  I called Comcast and complained.  They sent a tech out and he found that if he plugs into the cable modem directly, 150 meg no problem.  If he plugs into the LAN and thus routes through pfSense, he gets bad speed.  I rebooted pf, no change.  Reinstalled, no change.

    Any idea what may cause such a horrible degradation of performance?  CPU usage is near zip.



  • Back up your settings, reset to default and see if it works fine?



  • Thanks for the suggestion, I'll go try that.  Drat, no dice.  Speedtest still showing 9.46 Mbps.



  • I just tried booting my gaming rig with the live CD just so I could test other hardware.  Same slow throughput.  No idea why it worked fine before, but not now.  Comcast said they are having some SNR issues in my area, but that doesn't seem relevant since directly using the cable device yields proper speed.  Getting ready to bite the bullet and just buy a pf appliance, but I'm hoping to find another solution first as that's a bit pricey.



  • are you getting errors on your lan or wan interface? is the interface speed at 1gbit ? did you try the tuning tips for intel network cards (https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards)


  • Banned

    There is an interface mismatch somwhere in the setup. Find it and report back.

    I bet you have the WAN link running 100 full duplex and not autoneg.



  • I'm not sure how to check that.  Sorry, I'm a newb with pfSense and BSD.  However, it seems to have worked itself out.  I just noticed that I'm getting full speed.  Hopefully it stays that way!  Thanks for the tips all.



  • I have (had) the same throughput issue.
    I am running pfSense on dedicated firewall hardware.
    I just changed the power setting from adaptive to maximum on AC power, and that SEEMS to do the trick (seems, as I have done that just one hour ago).

    My interface setting in the dashboard shows 1000 BaseT full duplex.  In the configuration screen it shows Advanced.  Should I force it to autoneg?


  • LAYER 8 Netgate

    There is no such thing as gig without autonegotiation.  gig is always auto.  I don't know why pfSense shows 1000baseT and 1000baseT full-duplex.  There is no such thing as 1000baseT half-duplex.  My guess is both those selections do the same thing.

    The problem lies when the other end is hard-set at 100-full or 100-half.  Both sides have to be either hard-set to the same settings or both set to auto.


Log in to reply