2.2 shaper wizard bug? VOIP / PRIQ



  • I'm trying to use the shaping wizard in pfSense 2.2 to boost VOIP priority only, I don't care about anything else.

    From what I'm seeing, apparently you can't use the VOIP wizard option if you are using PRIQ. Though, I guess if you can't do that, why does it act like it can do it? It should detect that situation and not allow you to attempt VOIP prioritization.

    ================================

    PfSense 2.2

    Dashboard:
    WAN #1: 1000baseT <full-duplex>LAN #1: 1000baseT <full-duplex>LAN #2: 1000baseT <full-duplex>LAN #3: 1000baseT <full-duplex>Multi Lan/Wan Shaping Wizard
    –---------------------------
    WAN connections: 1
    LAN connections: 3

    Next

    LAN #1: MYTEL_VOIP    - PRIQ
    LAN #2: LAN            - PRIQ
    LAN #3: GUEST_WIRELESS - PRIQ
    WAN #1: WAN            - PRIQ
      Upload: 93 Mbit/sec
      Download: 93 Mbit/Sec

    Next
    –---------------------------
    VOIP prioritize: Enable

    Provider: Generic
    WAN #1  - 10 mbit upload guarantee
    LAN #1  - 10 mbit download guarantee
    LAN #2  - 500 kbit download guarantee
    LAN #3  - 500 kbit download guarantee

    Next

    Penalty box shaper: Not enabled

    Next

    Peer to peer networking shaper: Not enabled

    Next

    Network games shaper: Not enabled

    Next

    Raise or lower other: Not enabled

    Next

    Finish

    =============================
    Error: Custom Bandwidths are greater than 30%. Please lower them for the wizard to continue.

    Change VOIP config to:

    VOIP - prioritize
    Provider: Generic
    WAN #1  - 5 mbit upload guarantee
    LAN #1  - 5 mbit download guarantee
    LAN #2  - 500 kbit download guarantee
    LAN #3  - 500 kbit download guarantee

    =====================================

    Error: Custom Bandwidths are greater than 30%. Please lower them for the wizard to continue.

    Change VOIP config to:

    VOIP - prioritize
    Provider: Generic
    WAN #1  - 1 mbit upload guarantee
    LAN #1  - 1 mbit download guarantee
    LAN #2  - 500 kbit download guarantee
    LAN #3  - 500 kbit download guarantee

    =====================================
    Error: Custom Bandwidths are greater than 30%. Please lower them for the wizard to continue.

    Change VOIP config to:

    VOIP - prioritize
    Provider: Generic
    WAN #1  - 500 kbit upload guarantee
    LAN #1  - 500 kbit download guarantee
    LAN #2  - 100 kbit download guarantee
    LAN #3  - 100 kbit download guarantee

    …....................................

    Give up. Start over, but choose HFSC for all interfaces this time:

    Multi Lan/Wan Shaping Wizard
    –---------------------------
    WAN connections: 1
    LAN connections: 3

    Next

    LAN #1: MYTEL_VOIP    - HFSC
    LAN #2: LAN            - HFSC
    LAN #3: GUEST_WIRELESS - HFSC
    WAN #1: WAN            - HFSC
      Upload: 93 Mbit/sec
      Download: 93 Mbit/Sec

    Next
    –---------------------------
    VOIP prioritize: Enable

    Provider: Generic
    WAN #1  - 10 mbit upload guarantee
    LAN #1  - 10 mbit download guarantee
    LAN #2  - 500 kbit download guarantee
    LAN #3  - 500 kbit download guarantee

    Next

    Penalty box shaper: Not enabled

    Next

    Peer to peer networking shaper: Not enabled

    Next

    Network games shaper: Not enabled

    Next

    Raise or lower other: Not enabled

    Next

    Finish

    Succeeds, no errors.</full-duplex></full-duplex></full-duplex></full-duplex>



  • (Also, I realize 10 megabit is a ridiculously high bandwidth guarantee. But we've had VOIP delay / dropout problems and I want this fixed and not have to deal with it anymore.)

    Bit higher recently due to fone techs doing remote access monitoring over the voice VLAN:



  • Forget the wizard.

    Just create 2 PRIQ queues on the WAN. A default queue for all unclassified traffic, and another queue for exclusively VOIP.

    Then setup a floating rule in the firewall that directs all VOIP traffic into the proper, prioritized queue.


Log in to reply