PfSense - Captive Portal não funciona em interface Bridge



  • Olá à todos.

    Estou tentando configurar o captive portal para funcionar em uma bridge que fiz entre a WAN e LAN, mas a autenticação parece simplesmente não funcionar. O serviço fica habilitado, se eu colocar um IP na lista de "Allowed IP addresses" o mesmo navega na internet, mas nunca carrega a pagina autenticação quando removo. A interface que escolhi para habilitar o Captive Portal foi a bridge, já que o pfSense informa que interfaces que fazem parte de bridge não podem ter o portal habilitado.
    Segui basicamente este tópico para habilitar a minha bridge:
    https://forum.pfsense.org/index.php?topic=59925.0

    Montei, um cenário de testes com a seguinte situação:
    pfSense 2.2
    Modem: 192.168.1.254/24
    pfSense WAN: 192.168.1.4/24
    LAN: None
    OPT(Bridge): 192.168.1.5/24

    Modem(192.168.1.254)
                  |
                  |
            __ /______                                                                                                                  LAN(None)
            | SW_|–--------pfSense(WAN: 192.168.1.4 / Bridge: 192.168.1.5)---------|________________|---------Desktops 192.168.1.10-14
                  |
                  |
                  |
                /
                Servidores(192.168.1.2-5)

    Fiz a bridge pois não estão querendo que haja NAT da LAN(funcionamento atual) no ambiente de produção e ao mesmo tempo não gostaria de tirar o pfsense da topologia da rede.

    Obrigado,



  • Mas as 3 interfaces estão com a mesma rede? Não me parece certo, bem provável que haje muita confusão e muita coisa pode não funcionar.
    Melhor usar redes distintas para interfaces distintas.

    Esta com proxy nesta interface que o captive está ativo?



  • Na verdade somente 2 interfaces estão com IP(WAN e Bridge) a Lan está sem IP (Opção NONE). Deixei a WAN com IP pois caso contrário, o pfSense não consegue estabelecer conexão com a internet.
    Também concordo quanto a topologia da rede não ser muito adequada sem a separação da LAN, mas não é querer meu não ter uma LAN na situação. Não há proxy nesse ambiente de teste.

    Ambiente real:

    Recebo uma faixa de IP 10.120.130.0/24 de uma rede 10.0.0.0/8 semelhante ao tópico que citei no primeiro post. Tenho um pfSense fazendo um NAT da minha LAN(192.168.1.0/24) com a rede 10.120.100.0/24. Minha LAN tem squid e captive portal funcionando sobre ela.

    Agora estamos precisando fazer com que toda a LAN esteja na rede 10.120.100.0. Só nao queria deixar de ter o controle de regras sobre ela, por isso estou tentando fazer com o pfSense um firewall transparente, montei esse ambiente de teste para simular a situação. Até está funcionando mas quando ativo o captive portal não funciona mais…

    Vi nos fóruns gringos que o CP não funciona com bridge, mas outros dizem que sim...
    Talvez se alguém tiver uma observação de como fazer isso sem essa bridge, fico agradecido.

    Obrigado,


Log in to reply