Upgrade pfsense 2.1.5 -> 2.2 in citrix xenserver is unsuccessful



  • I managed to successfully upgrade version 2.0.2, but upgrade of 2.1.5 is a no go.  Clean install of the 2.2 also works without problems. After upgrade of 2.1.x firewall reboots and gets stuck during boot always on:
    Timecounters tick every 10.000 msec  (see screenshot in attach)

    I believe the message isn't indicative of the real problem as it appears in normal boot as well right before ipsec initialization and usb/ide initialization. But no other message is being displayed, CPU is 100% and VM makes no disk operations. Logically since this happens before disk controller initialization / is not mounted and I have nothing in logs.

    I've been doing upgrade both via webgui and console, same result. I did convert fstab to labels prior to upgrade, so disk names aren't the issue. I tried to disable acpi, dma, caching with no effect. As advised in troubleshooting guide:
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#Conflicting_Hardware

    I'm kind of stuck here and have no clue what else to do troubleshoot the problem. Help is more then welcome.



Log in to reply