Ftp passive problem



  • Hi, i'm with a problem do use ftp in passive mode.

    I trying to connect to a ftp server out of my work in command line. In my work we use pfsense firewall.

    I'm testing in a desktop with an IP with no blocks

    In common ftp works fine, in command line i have this error:

    500 i won't open a connection to "IP"
    425 no data connection

    What can i do?


  • Banned

    What command line? ftp.exe in Windows? It does not support passive at all.



  • But problem is… out of my work this passive mode works or if i use one connection that dont pass by pfsense works too


  • Banned

    As said above, ftp.exe in Windows does NOT support passive FTP at all… Period. Use the FTP client proxy package if you are on 2.2 and using retarded FTP clients. Also, kindly read this:

    https://doc.pfsense.org/index.php/FTP_without_a_Proxy
    http://slacksite.com/other/ftp.html



  • i dont understand…
    the problem is...
    i tying to connect to a ftp server OUT of my work i have to use command lines

    ftp>
    open> ...

    and with pfSense on my network does not work .. if I connect through a link directly without going through pfSense works


  • Banned

    I understand you perfectly fine. Read the links above. Use the FTP client proxy package on 2.2, or get a non-retarded CLI client that handles passive.


  • LAYER 8 Global Moderator

    As dok has mentioned if your using the windows cmd line ftp, it has NEVER supported passive.  So you must of been using active, pfsense before 2.2 had a ftp proxy/helper that would of helped with that.

    Now there is none, use the new package if you need active connections to work.

    In a passive connection the server sends you the port to connect to and the client connection.  Unless your filtering outbound traffic from the client there would be no issues in using passive from a client behind pfsense to a server on the public internet or on then wan side of pfsense.

    https://doc.pfsense.org/index.php/FTP_without_a_Proxy
    Active mode FTP through NAT will not function as that relies on a proxy or similar mechanism. Use Passive mode instead. Another option is the recently added FTP Client Proxy package which leverages ftp-proxy(8) in FreeBSD to allow clients on local interfaces to reach remote FTP servers with active FTP.


Log in to reply