Pfsense x Xenserver



  • Ola pessoal, instalei um Pfsense 2.2.0 e 2.2.1
    em um Xenserver, mas estou tendo um problema que nao estou conseguindo resolver

    no xenserver tenhos varios servidores virtuais em linux e fbsd10 funcionando normalmente
    adcionei o pfsense, e atribui 2 interface de rede, a interface 1 esta na mesma rede logica
    que os outros server virtuais, e a interface 2 é rede logica separada, com ip invalido e ligada em switch
    que vai para minha rede interna..

    quase tudo funciona normalmente nas estacoes da rede interna, exceto que nao consigo acesso a nenhum servico
    em maquinas virtuais que estao no mesmo xenserver que o pfsense, elas responde ping normalmente.
    mas acesso ssh, ftp , web  n, nao funciona..

    Alguem ja passou por isso  ou tem uma ideia do que pode ser ?!



  • As maquinas que você não consegue acesso, estão usando o pfsense como Gateway?



  • Nao…..
    Vamos ver se consigo explicar

    roteador  186.n.n.1
        switch -> servidor_fisico1 186.n.n.2
                  -> servidor_fisico2 186.n.n.3
                  -> xenserver 186.n.n.4
                                      -> servidor_virtual1 186.n.n.5
                                      -> servidor_virtual2 186.n.n.6
                                      ->  pfsense_virtual  186.n.n.7
                                                                  ->NAT
                                                                          ->pc1 192.168.1.2
                                                                          ->pc2 192.168.1.3

    o servidores fisico e virtuais estao na mesma rede logica ( 186.n.n.n ) e usam o ip do roteador como gateway
    o pfsense esta virtualizado, interface de entrada 186.n.n.7, interface de saida para rede interna, 192.168.1.1
    os pc´s acessam a internet normalmente, e acessa os servidores fisicos normalmente, mas nao acessa os servidores virtuais, mas pinga..
    fiz um teste trocando o pfsense por um linux fazendo nat, na mesma topologia e funciona;;;
    eu nao to axando explicacao logica e muito menos solucao para isso...



  • Ja verificou no firewall logs do pfsense o que ele está bloqueando?



  • Já tentou criar uma rota para que esses pcs que estão nessa faixa de ip acessem os serviços dos outros servidores que estão em faixas diferentes?



  • bom dia..

    Verifiquei regras de firewall, e nao tem nada bloqueando….
    e respondendo a dica de outro amigo do forum, Nao tem nada  haver com rota..

    pois como descrevi antes, as maquinas virtuais que estao na mesma rede logica eno mesmo vswitch, pinga normalmente..

    percebi que as vezes um determinado site que esta em maquina virtual comeca abrir o o site, cmom se o trafego fosse muito lento..
    mas  dai para por ai...

    e até agora nao axei solucao


Log in to reply