• Hello everyone,

    Im stuck.  I've been reading and experimenting for two days now and Im sorry to have to ask for help.

    I was inspired by stephenw10 and jp141 with the speedstep and pico power supply.  I've been using earlier versions of pfsense and decided that when I upgraded to a newer version, I might as well get rid of that power hungry power supply and go with the pico supply.

    I read the following posts:

    https://forum.pfsense.org/index.php?topic=20095.90

    https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox

    https://forum.pfsense.org/index.php?topic=46775.0

    and more.

    My problem is that I am not a programmer and I seem to have problems executing the instructions in the first two links above.  I set the timecounter in the system tunables with the following entry….. sysctl kern.timecounter.hardware=i8254 under the tunable name.  I describe it as "speedstep" in the description, and give it a value of default (1).

    I enabled powerd in system/advanced/misc.  however there were 4 options from the pulldown menu to choose from, I tried all 4 and get the same result.

    I attempted  ::) to add the next two lines to the /boot/loader.config.local but I cant seem to figure out how to add to or edit that file. 
    hint.p4tcc.0.disabled=1
    hint.acpi_throttle.0.disabled=1

    Ive tried to add the lines in putty and the gui command prompt, but I dont think it is being added.  I try to pull up my /boot/loader.conf.local file via the diagnostics/edit file by typing in /boot/loader.conf.local and hit load or browse, but nothing comes up.  I think this is my problem... I do not have the knowledge to edit or add to my /boot/loader.conf.local file.  I read that if it is a fresh install (which it is), there might not be a file to edit, but that is why Im asking.

    So the messages im getting from my serial interface are "timecounter TSC must not be in use when changing frequencies; change denied.  The message repeats.

    My system is as follows.....

    Firebox x750e CORE
    PFSENSE 2.1.5 nano serial installed on 4GB CF
    2gb ram (1x1)
    Intel SL7EP M735 1.7 GHZ 400 MHZ 2MB CPU (configured on the motherboard via DIP)
    VGA lead via populated header on MB (for bios)
    Keyboard Lead via populated header on MB (for bios)
    WAN MSK3
    LAN MSK2
    OPT1-OPT2 MSK1-MSK0
    OPT3-OPT6 SK3-SK0

    Pico 80w is not hooked up yet until I get the speedstep squared away.

    If someone has a "layman's" guide to complete all the steps to get this thing running, I would be very thankful.  Either way, I am appreciative for any input or help.

    Thanks,

    Tom

  • Netgate Administrator

    Dredging up an old thread here but seeing as nobody responded…
    If you're monitoring the thread and havne't got this working please ask again.  :)

    Steve