My *NEW* IDE CF is recognized by FreeBSD-6.0 – Success!



  • I wanted to add an update on my post below concerning the system not booting from CompactFlash.  It works now.

    I bought a new IDE adapter today, put it in a regular PC and installed pfSense from LiveCD.  Then I put the CF in my Mini-ITX and it booted but halted again the "mountroot" prompt.  But this time I could see that it at least recognized the drive and I was able to enter the proper one and it booted on up.

    To make this short, I found that the system would not boot properly with the CF adapter as anything other that the first drive on the first channel, regardless of whether it was the only drive in the system.  It may be that it only boots as the same drive the system was installed as and moving systems was a problem?

    I re-jumpered the adapter and put it on the first channel and it boots up every time now.  This is with the BIOS PIO/UDMA settings at "AUTO", though BSD sets it to PIO4.

    So far, I'm really impressed with the work you guys have done.



  • _Edit:  I worked on this for two hours last night before posting and going to sleep.  This morning it's working normally again:  local hostnames from DHCP are resolving, lease infromation is being written to /var/dhcpd/var/db/dhcpd.leases, and they show up in the web interface again.  Several reboots last night made no diifference. _

    Perhaps I spoke a little too soon.  When I installed from LiveCD, I made sure to not create the swap partition and I read the FAQ about changing /etc/platform to "wrap".  It still did not create a memory file system, everything was mounted RW and it was writing log entries.  I didn't find any of the scripts in /etc to reference PLATFORM of "wrap", so I changed it to "embedded", but that didn't change anything.

    Having figured out the CF IDE adapter, I decided to just put the BETA2 embedded version on it.  No problem getting it to boot up and work but something's not right with the DHCP/DNS.

    The web GUI refuses to show any leases any more, though there actually are several.  The local DNS seems intermittent now.  It worked fine with the install from the LiveCD.

    Some lease information is being written to /var/dhcpd/var/db/dhcpd.leases~ but not to dhcpd.leases.  Note the tilde.

    Here is output of mount"

    mount

    /dev/ufs/pfSense on / (ufs, local, read-only)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    devfs on /var/dhcpd/dev (devfs, local)      <–-- Is this right?
    /dev/ufs/pfSenseCfg on /cf (ufs, local, read-only)


Locked