Pfsense box died tonight - help with diagnosis



  • A week and a half ago I installed pfsense on a dell poweredge 2650. I added the squid package, but other than that was running stock. Everything went perfectly smoothly until 12:30 tonight at which time I found I was offline. I could ping the pfsense box, but from the pfsense box couldn't ping either a domain or ip address on the Internet. pfsense box is set to get wan ip via dhcp from dsl / actiontec dsl modem is set to bridged mode.

    The weird thing is that there were absolutely no changes on my end to either the dsl modem or the pfsense box, but all of a sudden around 12:30 a.m. it went offline and now will not get an ip via dhcp.

    At the command prompt after re-assigning wan and lan IPs, I get
    route: writing to routing socket: no such process
    route: writing to routing socket: no such process
    route: writing to routing socket: no such process
    route: writing to routing socket: no such process
    route: writing to routing socket: no such process
    route: writing to routing socket: no such process

    When assigning the wan/lan, after entering bge0, bge1, and then clicking y I also got
    please wait while reloading settings 231 not found

    I even tried reinstalling pfsense completely from the same cd image that I originally installed from, and still no luck.

    I also tried switching the lan and wan network cables and interfaces bge0/bge1 thinking maybe a nic went bad, but no luck there either.

    (I have an old p200 smoothwall box that does get an ip from the same dsl modem fine – I would put the pfsense install on that box, but that hardware is really really old.)

    The only thing I can think of is that somehow my poweredge 2650 died somehow at 12:30 a.m., but it really has me mystified.

    (I can for example ping the lan IP whichever nic it's connected to.)

    Any ideas before I tear my hair out?



  • OK, now I really don't get it.

    As I said above I tried both:
    1.) formatted raid-1 array, reinstalled pfsense from same cd as original, and
    2.) used the 'reset to factory' option

    and neither would get pfsense back online

    Then I downloaded smoothwall 3.0 and installed that from a cd to this same poweredge box, and it works fine (I'm posting over it now.) The only thing I did have to change was changed the perc3 controller from raid1 to scsi as smoothwall wouldn't install on the raid setup, so maybe something there…

    I can't figure out what would have changed with no change from me that would make pfsense all of a sudden stop running on this poweredge and not even be able to be reinstalled. Maybe some really really really wierd hardware glitch?(it is an older machine.) Truely odd though as smoothwall seems to be running fine on the same machine.



  • smoothwall is linux whereas pfsense is freebsd so that's something completely different and not comparable. Try installing from CD again with the smp kernel (even if you are on a single processor box). Also try to disable ACPI ( http://devwiki.pfsense.org/BootOptions ).

    Has this box been upgraded from older versions? What's the lifteime history of this pfSense install? Did you upgrade recently?



  • I did try reinstalling using the SMTP kernel (was only running SMTP kernel from the beginning on this box.)

    History was fresh install on March 15th of pfsense.

    Added squid package on March 16th.

    pfsense ran perfectly without a single glitch for 15 days until 12:30 a.m. on April 1st.

    Then suddenly there was no net connection even though dsl modem was up.

    The pfsense GUI was fine, but I could not ping, traceroute, or reach a domain or ip from the pfsense box.

    Rebooted, and found it was not grabbing an IP via DHCP from the dsl modem.

    Reset to factory using the menu link, no change.

    Formatted RAID-1 array that it had been installed on, reinstalled from CD. Still no IP via dhcp.

    Tried changing LAN and WAN (bge1 and bge0) - no change.

    Formatted and installed smoothwall on same machine, and it grabbed IP from modem right away and is running fine.

    Very very odd…

    Will look into ACPI now - thanks.



  • Maybe just resetting the modem would have helped?


Log in to reply