Android WLAN IPSec only one ping



  • Hi,

    I have a strange behavior with my android tablet, which is connected via WLAN (pfSense 2.2.1 on Alix) and bridged with LAN. So it's easy to access ressources in a remote lan which is connected over an ipsec tunnel on the Alix. Here's the problem:

    When I ping from the tablet to the remote ressource e.g. 192.168.10.1 … the first ping is successful. After that first ping, there is no connection possible anymore. If i do this direct from lan, ping works as it should work. Then I tried successful to ping from an iphone (also over WLAN) to that ip. The problem seems to be located at android side. But ...

    ... I have configured some domain overrides in dns resolver. The dns servers configured there are located in remote subnets which are accessible over the ipsec tunnels. To get that working I had to setup a "fake Gateway" in routing (my lan gw ip address) and then fake routes to put that traffic into the tunnel to reach those dns servers (found that hint here in the forum) ...

    And if I delete those fake route/gateway ... the problem on android side is also gone. So it must not be a exclusively problem on my tablet (android 4.4), it seems to be in interaction with the fake settings. This ist not a problem of dns resolver. I had the problem before with older configurations with dns forwarder.

    Does anybody has a clue how to get rid of that?

    Thx



  • Since I got no response, I'll give it a second try and bump the thread. Am I the one and only with that issue?


  • Rebel Alliance Developer Netgate

    That is quite odd. Have you tried from other access points to rule out an issue on the tablet?

    Does anything ever show up in the firewall log?

    Another possible explanation, your tablet is being run by Sean Connery and he's looking to defect…


  • Netgate

    Verify range to target…  :)


Log in to reply