After Upgrade to 2.2.1 webGUI not running



  • Updated today to latest version 2.2.1 and the webGUI is non-responsive, when i log into it via ssh i did a netstat -an and don't see anything listening on 80 or 443, tried running /etc/rc.restart_webgui it says it restarts it but still no response.

    thoughts?



  • so it seems like it upgraded with 32 bit data overtop my 64 bit install….not sure how but when i ran

    cp /usr/lib/libcrypto.so /usr/local/lib/libcrypto.so.7
    

    it let me start the webGUI but basically nothing works since curl isn't installed, or any other package but it let me in to backup my config, guessing re-install should fix it….i hope



  • My God!!!

    Someone who all on their own came to the conclusion that a totally screwed update might be best wiped and reinstalled.  And I didn't even have to twist your arm!

    I salute you sir!

    ;D



  • well thanks, I was going to no matter what since that'll fix it.

    The only reason I posted was for ideas or thoughts as to why but then i found the reason myself. I spend too much time doing this stuff at work clearly but hopefully anyone else who has this issue see's the problem or maybe a dev can see why it happened and prevent it in the future.

    Hope it helps others and might actually check this forum more now I signed up to make this post



  • I think your solution is common sense unless you are a dev trying to find an issue and fix in the pfsense release.


Log in to reply