Setting hard disk standby… failed



  • I just setup pfsense nanobsd 4GB for the first time.  I've converted to pfsense from monowall and restored my monowall config without issue (just went to restore config page and chose monowall.)  I'm using a USB to Compact Flash adapter on an Intel Desktop Board D2500CC that has an Intel Atom D2500.  The compact flash is an Wintec FileMate S Professional 8GB model # 3FMCF8GBS-R.  So far so good except for the one issue below that I noticed in the logs at start up:

    Setting hard disk standby… failed!

    I did some googling and searched this forums but haven't found anything relevant.  So far it hasn't seemed to affect anything.  I've been running a few hours without issue.

    When I looked at dmesg from exec.php I did not find the error "Setting hard disk standby... failed!" as it seems to be a configuration item in pfsense as opposed to boot from freebsd.

    I tried searching the admin portal for a setting related to hard disk standby (like monowall had) but can't seem to find anything.  Any help or guidance would be greatly appreciated.  Thanks!

    edited post to correct some typos


  • Rebel Alliance Developer Netgate

    That's normal/expected in some cases.

    Some controllers claim to support APM but fail when actually attempting to adjust the values.

    It's also possible that code doesn't even work properly on 2.2.x and can be completely removed.



  • Thanks for the info.  If you need me to do any testing or anything let me know.

    I forget to mention the USB to Compact Flash adapter is the following:

    SYBA SD-ADA50024 2.5" SATA/USB To Compact Flash Adapter, Model #:SD-ADA50024


  • Rebel Alliance Developer Netgate

    Looks like the function needs a rewrite for 2.2.x – https://redmine.pfsense.org/issues/4569



  • nice find, thanks!  In the interim, do I need to do anything to my current embedded install to ensure going into standby is disabled? (I'd imagine I do NOT want to allow the CF to go into standby)  Since it is compact flash and I am using the nanobsd 4GB version, I am not sure of the default values?  If by it not working properly in 2.2.1 means that it will NOT go into standby I should not have to do anything :)

    I'd imagine the below should do the trick if I do in fact need to set the value to 0 to ensure standby is disabled.

    set camcontrol standby ada0 -t 0
    boot

    then add:

    camcontrol standby ada0 -t 0

    to the /boot/loader.conf.local via /edit.php ?

    Output from my pfsense:

    $ camcontrol devlist
    <flash mo="" dule="" 0200="">              at scbus2 target 0 lun 0 (pass0,da0)</flash>

    $ sysctl kern.disks
    kern.disks: da0


  • Rebel Alliance Developer Netgate

    That's a command not a loader.conf value. You can add the shellcmd package and have it run:

    /sbin/camcontrol standby da0 -t 0
    


  • thanks for all the help!

    I went to /exec.php and ran the command.  Below is the output.

    $ /sbin/camcontrol standby da0 -t 0
    (pass0:umass-sim0:0:0:0): STANDBY. ACB: e2 00 00 00 00 40 00 00 00 00 00 00
    (pass0:umass-sim0:0:0:0): CAM status: Function Not Available

    I then installed shellcmd and added the below command to be run on system startup:

    Command: /sbin/camcontrol standby da0 -t 0
    Type: shellcmd

    Saved.  Rebooted.

    I am not sure if the shellcmd actually ran since I am not sure how I can verify either a) that my standby time is at 0, OR b) what the text result was when the command was issued?


  • Rebel Alliance Developer Netgate

    Then it sounds like your device doesn't support standby so it's not worth worrying about.



  • Thanks so much for the help and support.  I've removed the command from shellcmd.  Thanks!


Log in to reply