No connection possible from LAN to WAN



  • Hi there!

    I just downloaded pfSense an installed it on Harddrive.
    My simple Network:


    Internet
                |
          DSL-Router
              / 
    pfSense    internet-capable computers, connections work
          |
    simple W2K PC for testing


    My problem: I'm not able to ping from a computer in LAN to WAN. I tried both Hostnames (like www.google.com) and IPs.
    From pfSense-Box it's possible to ping any IP/Hostname in the internet (name resolving works, too) and it is possible to ping the computer in LAN.
    It's possible to ping from the LAN-PC to the LAN-IFace and to the WAN-IFace of the pfSense-Computer, but it isn't possible to ping the DSL-Router. I'm able to access the web configuration.

    I configured the IP of pfSense as the gateway of the PC in Lan. Actually, if I configure the IP of pfSense as the DNS of the PC in Lan, I see the hostname resolved when pinging, but the host stays unavailable.
    I disabled the firewall in pfSense completely, I work only with static IPs. There were no additional changes/configurations on pfSense made (maybe that's the problem?).
    I have 7 ethernet cards installed. I switched card-assignment, the problem remains. I searched the Wiki and the Howtos, but I didn't find anything helpful.

    Help appreciated…

    Thanks & regards,
    Fred



  • If you disable the firewall completely the system won't perform NAT any more. This means you would need a static route from the dsl router to the lan clients via the pfsense wan IP. Enable the firewall again to get NAT working again. Then just create firewallrules where needed to allow traffic. What happens now is that the lan clients arrive at the dslrouter with source IPs that the router doesn't know about so the traffic can't be returned. NAT will make this work again.



  • Hi!

    I reenabled the firewall and created rules for the LAN and WAN IFaces.
    I configured both to accept all packages, from all sources on all ports. Problem remains…

    Thanks, Fred



  • Reset to factory defaults and start over. Before doing any configurations make sure it's working (unless you have 192.168.1.0/24 on that dsl router and the dsl router does dhcp it should work out of the box). If that works start configuring again. Test in between for connectivity to see where it breaks. You probably misconfigured something along the lines.



  • Ah sorry, I missed to set the gateway right in Win.

    Now everything works just fine! Thank you very much!

    Without you I would have tried on and on with my firewall disabled…



  • Good to hear it's working now  :D


Log in to reply