Comcast IPv6 PD + PFSense Changing IPv6 Prefixes



  • Hi All,

    Cross posting from http://www.dslreports.com/forum/r29962083-IPv6-Comcast-PFSense-Static.

    Copied below is the content from that posting:

    My goals are pretty simple…

    1. Leverage IPv6 on my internal LAN, using PFSense's "ACLs" to control inbound access.
    2. Leverage DHCPv6 + BIND with dynamic DNS internally and a secondary zone with replication at dns.he.net to publish AAAA records.

    As has been said many times here it seems, you cannot configure the "track interface" setting on PFSense and also use a DHCP server. In my case, I've used "track interface" to identify the prefix and then configured the LAN interface to be a static IPv6 on that delegated prefix. Everything is configured and working properly and then stops working some days in. Switching back to a dynamic track interface configuration I see that the prefix has changed.

    From what I understand, this should only occur if either the backend routes adjust and I'm on a new CMTS, or my DUID changes. Any ideas why this is changing?

    Questions...

    1. Is there a better way to accomplish my goals?
    2. Is there a way to reliably use static IPv6 addresses with Comcast?



  • If Comcast wants to change your IPv6 prefix there is nothing you can do to stop them. It wouldn't surprise me if they change your prefix now and then just to make it hard for you to run a server. Maybe they can sell you a business class account with a static prefix assignment?



  • @antillie:

    If Comcast wants to change your IPv6 prefix there is nothing you can do to stop them. It wouldn't surprise me if they change your prefix now and then just to make it hard for you to run a server. Maybe they can sell you a business class account with a static prefix assignment?

    Yeah I'm hoping it's not nefarious. :)

    Issue is getting the speed/bandwidth on the business accounts. A 100MB line on Business isn't cheap…

    Or, if this enhancement gets applied to PFSense then it may resolve my issue.

    https://redmine.pfsense.org/issues/3029


Log in to reply