Pfsense 2.2.1 crached after upgrading ESXi host to 6.0



  • I'm running a server 2.2.1-RELEASE (amd64) on ESXi 5.5
    Everything worked greate. Got 1 WAN, 2 LAN and several VLAN on both LAN.
    I then upgraded ESXi to 6.0. Then everything crashed.

    LAN #2 and all VLAN running on that stoped working. At the dashboard interface status field it says "autoselect" on all VLAN og LAN 2.
    Under status -> interfaces it says no carrier on them.

    On the ESXi host every ethernet connection is as normal. All cables are working.

    Any good suggestions ?

    Is this Pfsense related or ESXi ?



  • Any good suggestions ?

    Go back to 5.5.  Wasn't 6.0 just released a week or so ago?  I'd definitely give it time to shake out any issues.  My entire corporate infra is based on vSphere, and there's no way in Hell I'm moving to 6.0 until at least Update1 comes out.  Besides, from what I've read 6.0 does nothing for you if you're not a giant mega-enterprise.  I'll get there eventually but I'm in no hurry to make major changes for no immediate benefit.  I'm still sitting on pfSense 2.1.5 for that same reason.


  • LAYER 8 Global Moderator

    I updated to 6 few days after it came out, no issues.  Pfsense 2.2.1 64 was on it before the update, after the update everything is fine.

    What is your hardware?  Issues with drivers for your hardware in 6?  So all your other vms are working, and just pfsense has issues?

    I'm not running in corp setup, with critical production requirements.  While I can understand not moving to current release of anything day it comes out in that sort of setup.  I have had no problems with any vms after moving to 6, updated all hardware to 11, updated all tools - pfsense using openvm tools vs vmware native.  Some sort of issue with the checksumming for sure.  You can get the native tools to work if you disable txcsum and rxcsum in the nic, etc.. But 10.1 has native vmx3 support so no real reason for the native tools

    All vms using vmx3, upgrade was click, click up and running.



  • I did a rolback to 5.5, and everything worked greate. Think I will wait for som ner updates, or test it on a different server before upgrading again.


Log in to reply