[RESOLVED] Unbound Domain override



  • Hi everyone

    I´m trying to setup a "Domain Overrides" n my pfsense box.
    I have my own TLD with my friends in a VPN net. My private tld is ".guifi"

    In DNS Resolver -> Domain Overrides I´m adding the following data:

    
    Domain: guifi
    IP Address: 10.0.100.1
    Description: DNS Server for guifi domain
    
    

    When I try to restart the "DNS Resolver" service, the service does not start
    What´s wrong in my config?

    Thanks in advance
    Regards


  • LAYER 8 Global Moderator

    Are you actually using resolver?  Or do you actually using the forwarder and putting your over ride in the resolver section and trying to start the resolver.. What error do you get in the log for why it won't start?

    What version of pfsense are you actually using?



  • Are you actually using resolver?

    Yes, I´m using DNS Resolver

    What error do you get in the log for why it won't start?

    php-fpm[78998]: /services_unbound.php: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '/var/unbound/unbound.conf:97: error: syntax error read /var/unbound/unbound.conf failed: 1 errors in configuration file [1428143372] unbound[90467:0] fatal error: Could not read config file: /var/unbound/unbound.conf'

    What version of pfsense are you actually using?

    2.2.1-RELEASE (amd64)

    In addition, I´m using the advanced options with this parameters:

    
    root-hints: /var/unbound/root.hints
    include: /var/unbound/ads.conf #blocking ads
    include: /var/unbound/local-blocking-data.conf #blocking malware domains
    include: /var/unbound/blocklg.conf #blocking ads from my LG SmartTV
    
    

    If I delete this options in the advanced box, the domain-overrides works fine.
    With this options and no domain-overrides settings unbound works fine.

    Thanks in advance


  • Banned

    Yeah, so there's absolutely no problem with domain overrides. Completely misleading thread subject. You need

    server:
    root-hints: /var/unbound/root.hints

    (RTM) though I have no idea what's your need to mess with root hints.


Log in to reply