Multi-WAN only one interface seems to be used



  • Version of PFSense:  2.2.1-RELEASE (amd64)

    I can't seem to find a clear answer on this.  I did find something similar to my problem here:  https://forum.pfsense.org/index.php?topic=69022.0

    I have a simple dual-wan setup, both cable connections.

    WAN1 	214GW     ----------------  Tier 1
          CRTR1GW  ----------------  Tier 1
    

    I have them in a group:  System: Gateway Groups
    I have them in the same Tier:  Tier 1
    I can unplug and interface and it fails over:  I get an alert and ping continues with a slight blip (normal for fail over)

    What I think is happening though is the default gateway is being used rather than it doing a round robin.

    When I look at:  Status:Gateways

    I see high latency on the middle modem.

    214GW 	x.x.x.x 	8.8.8.8 	18.1ms 	0% 	
     Online 
    Last check:
    Sun, 05 Apr 2015 07:47:05 -0500
    	Middle Modem
    CRTR1 	x.x.x.x 	8.8.4.4 	1.4ms 	0% 	
     Online 
    Last check:
    Sun, 05 Apr 2015 07:47:05 -0500
    	Charter Top Modem
    

    This might be due to the fact that 8.8.8.8 is responding in less time than is 8.8.4.4 but I don't think that's the case.  I think all traffic is going through the default gateway, the 214GW.

    When I go to:  System > Routing I see the 214GW as the "Default Gateway" and the other not marked as such.

    Is it safe to mark both as the default gateway or both as none in this setup?

    214GW (default)
    CRTR1

    Can you do that or should you do that?  Each interface of course has their own default gateway to the next hop but I'm thinking the default gateway option on the 214GW interface is messing with round robin as it should be according to the documentation.

    Thanks!  I'm a bit scared to do this as I'm not on site!



  • Answered!

    As always seems to happen I post in desperation but continue poking around.  The "fix" is to go into your LAN rules under firewall and scroll all the way to the bottom.

    Under:  Gateway > Advanced > drop the menu down to your gateway group > save and apply.

    That was the fix to push all traffic through the gateway group rather than the "default" or default gateway.

    I also noticed since I have ipv6 disabled that if I had any FW rule with ipv6 in it I didn't have the gateway group available until I made only an ipv4 rule.

    Dang!  Hope that helps someone.


Log in to reply