2.2-RELEASE to 2.2.1-RELEASE "The uploaded image file is not for this platform"



  • Hi

    Not sure why I am getting this. I tried to do upgrade from Dashboard link which takes me to System: Firmware: Auto Update. I click "Invoke Auto Upgrade" and it fails with "The digital signature on this image is invalid." A ls of /root gives me: $ ls -aolF /root
    total 315656
    drwxr-xr-x  2 root  wheel  -    3072 Apr  5 13:10 ./
    drwxr-xr-x  25 root  wheel  -      512 Feb 26 00:29 ../
    -rw-r–r--  1 root  wheel  -      898 Jan 22 15:07 .cshrc
    -rw-r--r--  1 root  wheel  -        0 Feb 26 00:28 .first_time
    -rw-r--r--  1 root  wheel  -      167 Jan 22 14:39 .gitsync_merge.sample
    -rw-r--r--  1 root  wheel  -        0 Jan 22 14:39 .hushlogin
    -rw-r--r--  1 root  wheel  -      229 Jan 22 15:07 .login
    -rw-r--r--  1 root  wheel  -        0 Feb 26 00:28 .part_mount
    -rw-r--r--  1 root  wheel  -      129 Jan 22 14:39 .profile
    -rw-r--r--  1 root  wheel  -      481 Jan 22 14:39 .shrc
    -rw-r--r--  1 root  wheel  -    1341 Feb 26 00:28 .tcshrc
    -rw-r--r--  1 root  wheel  - 86216498 Apr  5 15:20 latest.tgz
    -rw-r--r--  1 root  wheel  -      120 Apr  5 15:20 latest.tgz.sha256
    -rw-------  1 root  wheel  - 75268096 Apr  5 12:24 php.core

    Please notice the php.core dump a little earlier. So instead I go to System:Firmware Manual Update tab. I downloaded the 'pfSense-Full-Update-2.2.1-RELEASE-amd64.tgz' from a mirror (tried all US mirrors) The file's sha256 signature checks out. When I try to do this from within pfSense I get "The uploaded image file is not for this platform". Now this install is from a USB stick AMD64 version. I made sure I got the right file for that initial install. The only package I have added is SNORT. I read that uninstalling packages can me a difference. I will do that now and report back. TIA for any ideas.



  • OK

    Removing package…
    Starting package deletion for snort-2.9.7.0-amd64...done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.

    Package deleted.

    Still get:

    "The following input errors were detected:

    The uploaded image file is not for this platform."


  • Banned

    Kindly post the dashboard system information screenshot.



  • Hey thanks! Traction gotta like it  :) The dashboard screenshot is attached as .png 37Kb



  • Netgate Administrator

    Hmm, looks OK. Do you have any idea exactly what image you installed from?

    I don't know why your /var/run is showing as 108% but that's not good. If you reboot does that go down to some rational level? Try upgrading after rebooting.

    Steve



  • Stephenw10: I had rebooted after uninstalling snort before posting screenshot, so that is more or less post reboot. I had the same thoughts about /var/run. I gave this a 160GB disk, I like lots of logs and boosted the default sizes  :) but I am not sure why "/" got it all and /var/run got so little. I installed from pfSense-LiveCD-2.2-RELEASE-amd64-20150122-1403.iso I also generally like and use defaults so nothing strange there. I have to get this done today so I am just going to download pfSense-LiveCD-2.2.1-RELEASE-amd64.iso.gz and reinstall then restore my configuration. Thanks for the input, much appreciated.


  • Netgate Administrator

    /var/run should normally have almost nothing in it. Mostly the pid files of running processes. Either you have something odd going on, like thousands of processes or there's some calculation error happening.
    Either way installing 2.2.1 directly and restoring your config is the quickest way past this.

    Steve


Log in to reply