Added Nic, lost admin console



  • I am running 2.2 release(i386) on an older Compaq DL360G2 using the 2 built in NICS.
    everything worked until i added another compaq nic to the mix.
    When the system came back online, i needed to reconfigure the LAN and WAN
    nics as they had been renumbered.
    Everything came back online after i reset the nics EXCEPT the web interface, so i could not make any changes.
    When i reset the NICS, i tried using fxp0 for the WAN, fxp1 for the LAN and fxp2 for opt1 (did not work) so i used fxp0 and fxp1 for the WAN and LAN and left fxp2 undefined (still did not work).
    I was able (in both cases) to regain the ability to get off of the local net and out to google (as well as other sites), just no access to the Web console.

    Ended up taking the additional nic out of the system and resetting everything back.

    How can I add a second WAN nic to the system and keep the Web interface available?



  • Hi,

    The boot log (also visible after here /var/log/dmesg.boot) mentions that it actually finds your devices / 3 NIVs, like:

    rl0: <realtek 10="" 8139="" 100basetx="">port 0xd800-0xd8ff mem 0xefafdf00-0xefafdfff irq 18 at device 2.0 on pci3
    miibus0: <mii bus="">on rl0
    rlphy0: <realtek internal="" media="" interface="">PHY 0 on miibus0
    rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xdc00-0xdcff mem 0xefafe000-0xefafefff irq 19 at device 3.0 on pci3
    sis0: Silicon Revision: DP83816A
    miibus1: <mii bus="">on sis0
    nsphyter0: <dp83815 10="" 100="" media="" interface="">PHY 0 on miibus1
    nsphyter0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    fxp0: <intel 10="" 100="" 82801gb="" (ich7)="" ethernet="">port 0xd4c0-0xd4ff mem 0xefaff000-0xefafffff irq 20 at device 8.0 on pci3
    miibus2: <mii bus="">on fxp0</mii></intel></dp83815></mii></natsemi></realtek></mii></realtek>

    (I know, I'm using a nasty realtek one - and an even worse "NatSemi" NIC, but as up to today, they never let me down  ;))



  • All 3 interfaces showed up after the install.
    I went into the "assign interfaces" and all 3 were available.

    I left the new nic disconnected at one point to see if that would help.

    The only thing i was ever able to get (with all 3 nics installed) was a 503 service unavailable from the webgui address/port.


  • Banned

    Did you install bandwidthd?


Log in to reply