Pfsense installed no internet



  • Hi guys! I'm new to PfSense and in a few days I will have two internet connections available, but as of the moment I only have one internet connection. I researched and read so many threads about my problem and copying them( them meaning the solutions to the other threads ) and none of them have worked, It's been two days now and I can't get it to work I was making progress but now It has stopped please any help would be appreciated. :D

    My preferred setup would be modem > pfsense > router > gigabit switch.
    My current setup is modem > router (pfsense is connected on router lan) > gigabit switch. I did this because I was not making any progress and started configuring pfsense from there.

    I have 3 NICS available ( 2 ethernet cards [ intel and TP-link , 1 onboard card ). WAN (wan) / LAN (lan) / WAN2 (opt1)

    WAN - The wan seems to be working well, I can ping outside to google.com / yahoo.com / facebook.com ( Configuration is DHCP )
    WAN2 -  to avoid more complications I didn't enable WAN2


    LAN Scenario #1  PFsense LAN IP: 192.168.1.25 / 24  Router Lan IP: 192.168.1.1 (I did not connect PFsense Lan to Router WAN)
    Setup: Modem > PFsense > Router ( disabled NAT, enabled Dynamic Router RIP,disabled DHCP Server) > Switch (computer connected to switch)
    Problems: PFsense can ping google.com and other websites using WAN . Computer Can Ping PFsense LAN. I can also access WEB GUI. But Computer Cannot ping WAN or any other websites.
    Potential Problems: Meaning pfsense lan and pfsense lan does not communicated?

    LAN Scenario #2 PFsense LAN IP: 192.168.1.25 / 24  Router Lan IP: 192.168.1.1  ( I connected PFsense Lan Directly to computer Lan )
    Setup: Modem > PFsense > Computer
    Problems: Pfsense Wan can ping outside. Pfsense Lan does not detect computer Lan vice versa.
    Potential Problems: I can only detect pfsense when using my router (I am not sure about this but thats what I concluded)


    I also tried the firewall settings but it didn't work…
    I am stuck can anyone help me please? I read pfsense quite some time now and I am so amazed by it, but I can't get it to work:(







  • Banned

    You cannot have WAN and LAN on the same subnet. Plus, bridge the modem instead of double NAT.

    (Your keyboard is missing PrintScreen button, or what?)



  • Hello doktornotor!  ;D That reply was fast! Thank you so much! I am sorry about posting using my phone, I just remembered now that I can use Print Screen on my computer totally forgot that  :(

    About the subnet, which subnet should I change the router or pfsense? And what number should it be? When I change my subnet the problem will no longer occur?

    Thank you! :D



  • I configured my PFsense lan to be 192.168.1.25 and changed the subnet to 255.255.0.0

    and my router settings to (see attached image) after I set the settings, my router disappears and I can't access it from my network when I type "192.168.1.1 or 192.168.0.1" it doesn't appear. And my computer says that the Ipconfiguration is wrong,  :(






  • I did not understand your network, a picture is welcome.

    I would let pfSense do routing and firewall. Depending on your LAN topology (it seems single subnet) probably you don't need an additional router, with RIP enabled, a basic switch is enough. If you need wi-fi, you can simply use a AP (with NAT, DHCP, Firewall disabled).

    Modem->pfSense->Switch->Clients.

    Check your NAT outbounds rules, let them in auto configuration…then you can change to manual, just to test connectivity.
    Check Firewall rules.

    If you want, post those screenshots here.



  • @Wolf666:

    I did not understand your network, a picture is welcome.

    I would let pfSense do routing and firewall. Depending on your LAN topology (it seems single subnet) probably you don't need an additional router, with RIP enabled, a basic switch is enough. If you need wi-fi, you can simply use a AP (with NAT, DHCP, Firewall disabled).

    Modem->pfSense->Switch->Clients.

    Check your NAT outbounds rules, let them in auto configuration…then you can change to manual, just to test connectivity.
    Check Firewall rules.

    If you want, post those screenshots here.

    Hello Wolf666! :) I tried your suggestion Modem > Pfsense> Switch > Clients. I removed my router, but when I do that my computer doesn't detect the pfsense. I cannot detect pfsense and can't access web gui.
    It only detects the pfsense if you put the router into the network. maybe my pfsense has a setting that It doesn't detect my computer?

    Pfsense
    WAN: v4/DHCP4: 122.2.199.207/19 (this works I tried pinging website it works)
    LAN: v4 192.168.1.1/24 (I tried this it didn't work) / 192.168.1.25/16 ( I also tried this it didn't work) :(

    here are the errors that the computer give.

    Thank you wolf for you help :)





  • Banned

    @stormrage:

    LAN: v4 192.168.1.1/24 (I tried this it didn't work) / 192.168.1.25/16 ( I also tried this it didn't work) :(

    Noooooooooooo. Please, get some network calculator. You certainly do NOT ever fix a subnet overlap by going from /24 to /16. Look, what's the Linksys thing doing on WAN at all? It's not a modem at all, does nothing useful there beyond creating mess. You use that in bridge mode as access point. It just should not sit in front of your pfSense box at all. Put it on LAN or some OPT.



  • Let's do it simple.

    Taken into account you have a working pfsense WAN IP, got via DHCP.

    Set:
    1 - pfSense (LAN) IP 192.168.1.1/24 - set DHCP server scope 192.168.1.100 - 192.168.1.150 (if you need DCHP)
    2 - Linksys IP 192.168.1.2/255.255.255.0 (disable NAT and DHCP server), set default gateway 192.168.1.1.
    3 - Connect pfSense LAN to any LAN port of Linksys, also linksys WAN port should work if AP mode is supported.
    4 - Connect the Switch (if you need) to a spare Linksys' LAN port.

    Now any wired, wireless client should receive an IP from pfSense DHCP or, in case you are using static mappings, use their own IP  (set them between 192.168.1.3-99 and 192.168.1.151-254, outside DHCP scope).

    ALL your LAN is inside 192.168.1.0/24.

    Check your outbound nat, check firewall rules.
    Let us know if this simple configuration works.



  • @Wolf666:

    Let's do it simple.

    Taken into account you have a working pfsense WAN IP, got via DHCP.

    Set:
    1 - pfSense (LAN) IP 192.168.1.1/24 - set DHCP server scope 192.168.1.100 - 192.168.1.150 (if you need DCHP)
    2 - Linksys IP 192.168.1.2/255.255.255.0 (disable NAT and DHCP server), set default gateway 192.168.1.1.
    3 - Connect pfSense LAN to any LAN port of Linksys, also linksys WAN port should work if AP mode is supported.
    4 - Connect the Switch (if you need) to a spare Linksys' LAN port.

    Now any wired, wireless client should receive an IP from pfSense DHCP or, in case you are using static mappings, use their own IP  (set them between 192.168.1.3-99 and 192.168.1.151-254, outside DHCP scope).

    ALL your LAN is inside 192.168.1.0/24.

    Check your outbound nat, check firewall rules.
    Let us know if this simple configuration works.

    Thank you Wolf 666 and Doktonotor :) I will try this configuration and update immediately, I was really intimidated by the network calculator awhile ago. Thanks!  :)



  • @Wolf666:

    Let's do it simple.

    Taken into account you have a working pfsense WAN IP, got via DHCP.

    Set:
    1 - pfSense (LAN) IP 192.168.1.1/24 - set DHCP server scope 192.168.1.100 - 192.168.1.150 (if you need DCHP)
    2 - Linksys IP 192.168.1.2/255.255.255.0 (disable NAT and DHCP server), set default gateway 192.168.1.1.
    3 - Connect pfSense LAN to any LAN port of Linksys, also linksys WAN port should work if AP mode is supported.
    4 - Connect the Switch (if you need) to a spare Linksys' LAN port.

    Now any wired, wireless client should receive an IP from pfSense DHCP or, in case you are using static mappings, use their own IP  (set them between 192.168.1.3-99 and 192.168.1.151-254, outside DHCP scope).

    ALL your LAN is inside 192.168.1.0/24.

    Check your outbound nat, check firewall rules.
    Let us know if this simple configuration works.

    Thank you so much Wolf666! It worked! I did what you suggested and turned on the enabled Dynamic Router RIP, then after that I switched my WAN intel nic to LAN, and LAN tp-link nic to WAN, then it worked! I saw some lights on the tp link nic was not blinking (there are 3 blinking lights, only 1 is blinking) so I tried to switch it to WAN. Then it worked! Thank you wolf666! I'll study this to learn more about pfsense.  :)


Log in to reply