IP not working. Internal route tables?



  • Hello,

    I have PFSENSE running transparently bridged.

    I'm in the process of moving a server and something really odd is happening on the network.  The server had a public internet IP of something like 24.x.x.100  Been working for years.  I set up a new server with an IP of 24.x.x.101 for testing and it worked fine.  When it came time to do the actual move I shut down the old server and  changed the IP on the new server from 24.x.x.101 to 24.x.x.100.

    I can ping other servers of mine in the 24.x.x.x range but I can't ping anything outside of my network.  I set the pfsense firewall rules to pass everything so nothing should be blocked.  I still can't ping outside the network.  I've reboot pfsense.  The thing is, the IP that doesn't work is the same IP that has always worked when it was on the old hardware.  The new server does not have a firewall or anything else that would block just the one IP.

    I'm really stumped.  The new server is the same OS with no changes as the original server. Its just sitting on new hardware.

    Does pfsense keep some kind of internal tables related to a mac address or something?  I'm going to have to test with the firewall physically removed but I was curious if anyone had any ideas.



  • New server at 24.x.x.100 can't ping non 24.x.x.x/ <netmask>addresses?  Is the route table ok?  Default route?  Can you boot up the old .100 and check it's route table for comparison to the new server route table?  Was the new server able to ping outside the network when it was at .101?  Any upstream devices that may have the old server mac associated with 24.x.x.100 that needs to get flushed (static arp entries)?

    Sorry it's not a solution, and I'm assuming you've already looked at this type of stuff,  but more data to help figure it out.</netmask>



  • I'd go with flushing the ARP cache of the upstream router/switch myself.



  • The ARP cache looks very likely to be the culprit.  I will power cycle everything on the network after I make the change and see if that doesn't do it.  Thanks!



  • Did you get a chance to power cycle everything, if so did it "fix" the problem?


Log in to reply