Problema ao abrir sites HTTPS e que possui Flash Player



  • Boa Tarde, Pessoal

    Após configurar o squidguard, estou tendo dificuldade de acessar sites https.
    Ex.: youtube.com.br, google.com.br e outros…

    E também tenho dificuldade com site que tem flash player.

    Ficarei muito agradecido pois esse é único problema que ainda não coloquei o meu firewall para rodar geral.

    Obrigado!!!



  • Quais as categorias que ativou o bloqueio?



  • Este teste é na minha máquina, onde eu liberei tudo!!!



  • Precisa passar mais informações de como está sua configuração.
    Eu recomendo desligar Squid/SquidGuard e ir testando um de cada vez e ver onde aparece o problema, e ir ativando as regras uma por uma.



  • Eu já fiz isso, eu baixei uma lista de sites (Blacklist), mas deixei tudo liberado (allow). Mesmo assim não tive sucesso!!!

    Liberei no proxy serve na aba ACLs em Whitelist os domínios: YouTube.com.br; google.com.br. Mesmo assim, quando tento acessar o browser, ele fica processando um tempo e depois dar falha de conexão segura.

    A única forma que consegui acessar esses domínios, foi quando coloquei o meu ip no Bypass proxy for these source IPs. Ai sim, dessa forma consegui.

    Mas não quero resolver dessa forma, pois assim o ip acessará tudo na net.

    Deu pra entender gente a minha situação ?

    Desde de já agradeço!!! :) ;) :D



  • Você ativou o proxy transparente para HTTPS?? Se sim, instalou o certificado?



  • Sim Amigo, ativei o proxy transparente e instalei o certificado. :)



  • Olá mauricio1987,

    Você colocou suas subnets em Allowed subnets?

    No modo transparente o squidguard não vai bloquear tráfego HTTPS do youtube, nem mesmo o squid. Para o serviço do squidguard pra ver como fica.



  • Sim coloquei a minha subnets no server proxy.

    Agora eu consigo abrir o site, porém o mesmo abre todo desconfigurado, só os textos.

    E agora, o que pode ser isso ?



  • mauricio1987 Como estão suas configurações de Firewall e squidguard?

    Você está usando proxy transparente com inspeção de ssl correto? Já tentou desativar a inspeção e deixar apenas com proxy transparente liberando as conexões 80 e 443 nas regras de firewall?



  • Ok Amigo desabilitei a inspeção ssl deu certo, mas não consigo agora bloquear o facebook e nem o youtube.

    Como faço agora ? Como liberdo as regras especificas para as portas 80 e 443 como vc sugeriu ?

    Lembrando, sou iniciante peço uma compreensão maior!!!

    Desde de já agradeço!!!



  • Se você desabilitar a inspeção não vai conseguir bloquear esses sites HTTPS. Para utilizar esse recurso você precisa exportar o certificado e instalar nos clientes. Assim vai conseguir bloquear ou liberar utilizando o squidguard. Pelo que estou entendendo você quer liberar apenas para alguns clientes.

    @mauricio1987:

    Como faço agora ? Como liberdo as regras especificas para as portas 80 e 443 como vc sugeriu ?

    Em Firewall > Rules > LAN (Sua rede LAN) Cria uma nova regra com a porta de destino HTTP e outra com o destino HTTPS.

    Segue link do tópico de tutoriais:
    https://forum.pfsense.org/index.php?topic=8930.0

    Dica:
    Já pensou em utilizar o proxy configurado no cliente? De uma olhada nesse recurso (WPAD) ele configura o proxy dos clientes automaticamente. Dessa forma não precisa fazer inspeção SSL, vai conseguir bloquear através do squidguard, criando grupos para clientes que devem ter acesso.

    WPAD: http://www.pfsense-br.org/blog/2013/12/configuracao-wpad-no-pfsense-2-1/


Log in to reply