MTU size & pppoe performance



  • Hi all,

    Do you have clue how the mtu can affect the performance? On my pppoe connection the performance is quite poor.I use the default 1500 value.
    My isp uses 1492. I know i can use 1508 to avoid TCP MSS clamping. Can this increase performance?



  • nobady?
    any clue?
    can I somehow make use of the huge RAM i have…some buffers or something.



  • found an intel driver for this NIC.unfortunatelly i'm not able to compile it.
    https://downloadcenter.intel.com/download/17509/Network-Adapter-Gigabit-Base-Driver-for-FreeBSD-
    any clue?



  • @nikkon:

    found an intel driver for this NIC.unfortunatelly i'm not able to compile it.

    Nor do you want to. What's built-in is the best suited driver available.

    @nikkon:

    My isp uses 1492. I know i can use 1508 to avoid TCP MSS clamping. Can this increase performance?

    We don't have support for that currently. If your ISP requires 1492, it won't work anyway. It won't make any worthwhile performance difference regardless.

    @nikkon:

    can I somehow make use of the huge RAM i have…some buffers or something.

    no. Buffers are sized reasonably for the use case. Bigger than that, and see problems of buffer bloat.



  • thx for the answer.
    I still did some test modifications and i got +200 mbps

    /etc/sysctl.conf:

    net.local.stream.sendspace=82320
    net.local.stream.recvspace=82320
    net.inet.tcp.local_slowstart_flightsize=10
    net.inet.tcp.nolocaltimewait=1

    net.inet.tcp.delayed_ack=1
    net.inet.tcp.delacktime=100

    net.inet.tcp.mssdflt=1460
    net.inet.tcp.sendspace=78840
    net.inet.tcp.recvspace=78840
    net.inet.tcp.slowstart_flightsize=54

    net.inet.tcp.inflight.enable=1
    net.inet.tcp.inflight.min=6144

    Is this not recommanded?



  • +200 Mbps as measured by what?

    Everything you set there affects only traffic initiated by the firewall itself, which is generally little to none.



  • the only tool i have now is speedtest-cli
    i know is not consistent…may be the network congestion low @ the moment...no idea...is faster now.i could have the same ~300 in the morning



  • Dear nikkon,

    what i faced that if you set gateway monitor with pppoe connection you definitely get bad result. I dont know why. R u using the same.

    My two WAN loadbalance was not performing well for this. One is Lease Line of 5 Mbps and pppoe broadband of 4mbps. I enabled the gateway monitor for both. for lease line its ok. but for pppoe its not a good idea. after switching of the monitoring on pppoe, i m getting 9mbps speed now.. 8) 8).. check it.. MTU i havent set. I used default..


Log in to reply