Publish Exchange 2013 With squid3



  • Hi
    i am trying to setup a reverse proxy to my exchange 2013 i am using PF 2.2.1 and squid 3.4.10_2 pkg 0.2.7

    Reverse Proxy interface = Wan (Pool off 8 IP Address)
    User-defined reverse-proxy = none
    external FQDN = autodiscover.mime-time.com
    Enable HTTP reverse mode = default port 80
    Enable HTTPS reverse proxy = default port 443
    And I exported my exchange certificate and the CA
    Ignore internal Certificate validation = checked

    OWA Reverse proxy General Settings
    Enable OWA reverse proxy = checked
    Enable ActiveSync = checked
    Enable Outlook Anywhere = checked
    Enable MAPI HTTP = un checked
    Enable Exchange WebServices = checked
    Enable AutoDiscover = checked
    I have created a NAT roll to my exchange server
    when i atemte to access OWA i

    When I attempt to access OWA I am blocked by the firewall default deny on wan interface
    So what am I missing
    Thanks Daniel



  • Any One !!



  • OK I am Lost
    And if you take a look on this settings you will see that you are not using the reverse proxy
    As it turns out the Nat rolls negates the Proxy settings
    the reasen for that is the way the Nat is configured
    Or am I missing something
    http://www.moh10ly.com/blog/pfsense/publishing-exchange-on-pfsense
    Thanks Daniel