W7 MTU jumbo frames



  • Hello,

    I have a client with a small network consisting of (6) W7 PCs and a pfSense box. When I try to copy files from one PC to another I get dismal speeds (100Kb-500Kb). I'm using a single 3GB ISO as my file copy tester. It doesn't matter which PC I copy to or from and the shares are basic peer2peer. The switch is a Netgear JGS524 1Gb. The theoretical speed should be about 115MB/sec, and I'm expecting in the 80s MB/sec.

    pfSense is used as a router and DHCP server.

    I manually force jumbo frames to 9K and the speed jumps up to 85MB/sec.

    What I'm wondering is if pfSense is 'suggesting' a 1500 MTU size when the W7 boxes boot and pull an IP address. If so, is there any downside to forcing the W7 boxes to be 9K jumbo frames? I was under the impression that jumbo frames were a good solution in 2010(ish) but now everything auto-tunes itself to the fastest network speed. Also, what if I set the the MTU size on my LAN adapter setting in pfSense to 9000? Would this 'suggest' jumbo frames to the W7 PCs?

    The hardware is a basic MSI AM1I mobo, 4GB RAM, 60GB SSD, with a HP NC364T (4) port 1Gb network card.



  • Something is still weird.  With an MTU of 1500 on a GigE network, you should be able to do 40-60 MB/s no problem.  I just grabbed an ISO from my file server on our corporate LAN and it came in at ~56 MB/s.  I tried converting our network to jumbo frames but there always seemed to be phantom problems and weird connectivity issues.  After reverting back to 1500, all our problems disappeared.



  • I agree that I should not need to enable jumbo frames but I don't see any other issues so far.

    This started the first day of install with (3) PCs on the network.

    Since then one of the PCs is running Lytec 2015 a MS SQL Server medical office app and I've added another network. The PCs have AVG (antivirus which adds 'AVG Network Filter Driver' to the LAN adapter cards on the PCs)

    Yesterday we swapped out the switch with no change. The previous switch and the router were rebooted a few days back. That evening I tried a file copy and got 80MB(ish) results but by the next morning the speed dropped down and it hasn't gone above the 500Kb since then, even with the new switch.

    –---------------------------------
    Red Herring Warning
    The network now has

    WAN: static
    LAN: 192.168.128.0 /24
    OPT1: 200.0.0.0 /24 > yes I know this is wrong but it is an inherited legacy issue that is not going away, on that network is a SCO 5 server running a terminal app that gets traffic from the LAN side, I know there is a 100Mb card in there that may be half-duplex

    While the pfSense was configured for OPT1 on day 1 the server was not in place until a few days later. The problem started immediately.

    Ultimately I don't believe this to be a pfSense issue, I think it will be a W7 issue. I'm just trying to eliminate the router and 'who determines the MTU speed' issue.



  • It just occurred to me that if all these clients are on the same network then I don't see how pfSense would even come into it.  The clients are talking directly to each other via the switch.  Your switch usually has MTU settings, as do the NICs in your clients.  If you have a dumb hub then you might try that to isolate the switch as the cause.  Any packets loss when you do heavy file xfer?  Depending on your NICs and switch, you may have stumbled upon a weird incompatibility in network features but that's less likely I would think.


  • Banned

    As said above, this does not go through pfSense at all. Get rid of AVG in the first place (afraid the only reliable way of doing so is to re-image the machine). As a closing note, with junk like half-duplex fast ethernet legacy god knows what on your network, just totally forget about any jumbo frames. (This jumbo stuff is just a way to shoot yourself in the foot instantly, TBH.)


  • LAYER 8 Global Moderator

    "With an MTU of 1500 on a GigE network, you should be able to do 40-60 MB/s no problem"

    Higher than that..  I see right around 100 all the time, sometimes even over.  Write is even close to 90..  This is on shoestring budget hardware..  That test is from a physical machine old dell xps 8300 with built in gig nic (broadcom even) and to hp n40L with vm hosting up the files via raw mapped access to old disks..  Shoot the host doesn't even have sata 3 connections to the disk..  And the nic in the host is a $35 card.. Best thing that connects them is a sg300..  This is HOME budget stuff and see 100..

    Here test just did.. see attached..  You do not need jumbo frames to get decent speeds.. You got something else going on..




  • Jumbo frames are totally pointless on any remotely modern network. Building TCP/IP headers for lots of packets hasn't been a CPU bottleneck issue for ages and routers can do much more PPS now than they could 10 years ago. Same for switching hardware.


Log in to reply