Upgrade went wrong - now I cant even connect with serial cable



  • I tried to upgrade my Pfsense appliance but after flashing the firmware the device couldnt be seen on the network again.

    I attached a null modem cable to try and see what's wrong with it, but the output of the screen is barely intelligible. I tried connecting via a linux box using screen like this:

    screen /dev/ttyS0 9600,cs8,-parenb,-cstopb,-hupcl
    

    I can barely make out that the device is booting, the last thing to be seen on the screen is this

    Here is the output I do see on the screen

    data=||iFreeBSD/evision reeBSD_8naps.pfs18:16 EST 2011)
    Bootingernel] ikernel/k        The Free, 1989, ents of f Califo reserve registe The Frentegrate498.05-MHz 586-c = 0x5a2 = 5  Model = a  Steppin FeatureC,MSR,CXres=0xc056 MB)
    agree wal.intelense_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xor 1
    OD_LOAD c07011d0.conf.you icense, nse_ack=r.conf.
    D_LOAD (0xc07012K6-famil20100331rypto> oadlock0:pcib0: <ge>pcib: PC Eng9h tinyB7-2007
    device 1.2 (no ttached)00BaseTX000-0xe0: Quirkssion: 0x <mii buukphy0:="" ia="" interiibus0<br="">T-FDX, 1, 100basREAD]
    vr1: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1400-0x14ff mem 0xe0040000-0xe00400ff i10.0 on ision: 0s> on vrukphy1: 2.3u mediibus1
    , 10base, 100basr1: [ITHvr2: <vi>port 0 0xe0080 device 2: Quirkvr2: Revmiibus2:PCI-ISA port 0x60-0x61ff0x623f,03f at de0
    isa0: <isa bus="">on isab0
    atapci0: <amd cs5536="" udma100="" controller="">port 0x7,0x3f6,177,0x37e 15.2 oata0: <a<br>ata1: <ata 1="" channel="">on atapci [ITHREAohci0: <sb 12="" contrfe000-0xat="" devicohci0:="" [usbus0:="" e)="" usb="" 2em="" 0xeff="" irq="" ehci0:="" [:="" ehci="" vusbus1:="" 2.0="" cont<br="">cpu0 ot iomem  isa0
    afound.
    compati irq 4 f0 on isaock_battr "TSC" y 498054uality 8countersInitialiing.
    us
    usbus1gen0.1:
                  uhub0: <amd 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus0
    ugen1.1AMD EHCI 9/0, rer 1> on 1MB <cf k="">at atGEOM: addoes notnt waitiusbus1
    uhub1: 4 / was nh dumps.ting filting up nment…denied. tem is nsck
    mouation no/dev/ufs/pfseames
    ** Phase - Check8 frags,.1% frag *****
    ** /dev/ 2 - Che Phase 3* Phase 4 - Checnce Counhase 5 -les, 413ee (26 fks, 0.0%
                                                                                    ED CLEAN *****

    __f
    / p
          _
    pfSense
                      Creatin config appendin done.
    Initiali.[/font]

    I've tried 115200 baud aswell as 38400 neither seem to work! Is this some emulation problem?</cf></amd></sb></ata></a<br></amd></isa></vi></via></mii></ge>



  • Looks like an ALIX, which should be 38400 by default. Though the baud rate you were using where you got that text has to be correct, otherwise you wouldn't see anything legible like that. The weirdness of the display makes me wonder if it's a USB to serial adapter issue (hardware or driver).



  • After Googling ALIX, it certainly does look like one.  The connection is from a serial port on a linux desktop to the serial port on the appliance via null modem cable, no USB involved at all. I had slightly better luck using minicom instead, but 9600 baud is the only speed that will work sort of. It doesnt appear to be taking any input.

    What can I do now? Can I flash the appliance again? I've effectively bricked the device, unless I can find a way forward


  • Banned

    Sure, just remove the CF card and reinstall.

    https://doc.pfsense.org/index.php/Writing_Disk_Images



  • Fresh install 2.2 with PuTTY. Alix HW output reads with 9600 or 38400. pfSense 1st boot & base setup output works with 115200. Until you've set 38400 in webgui.


Log in to reply