Cannot create a Gateway that is a remote OpenVPN Gateway



  • Hi All,

    I need to create a Gateway that represents the remote end of a site to site OpenVPN-Connection. The reason for this is that I have a static route pointing to a Etherconnect-Gateway that shall be the primary connection to the remote desitination. But in case this fails, I want to use the OpenVPN-connection defined on the pfSense Cluster. But I need to use an interface when creating a gateway, but cannot select the existing VPN-Interfaces. I tried a virtual Interface, but this cannot be used either.
    Does anybody know an elegant way to solve this?
    I tried to find a suitable answer in the forum, but it looks like this is a rather unusual setup.

    Many thanks in advance.

    Regards,

    Jens



  • I am thinking you have gone to Interfaces->(assign), selected the OpenVPN instance in the Available Network Ports drop-down and pressed "+". That will give you an interface on the OpenVPN instance. Then you should be able to make a gateway on that interface.
    After that you can use the gateway in rules, static routes and so on to achieve whatever routing behavior is needed.



  • Hi,

    thank you for this hint. I tried that and it really looked promising, but I end up with another error. I can create the interface, but adding the gateway fails with the attached error. I also tried to add the Interface without an IP, as the IP is configured in the OpenVPN definition, but this yields the same result.
    Still thanks a lot, I have not looked there to add an interface name. I think I need to have a closer look, I am sure there will be a solution.

    Kind regards,

    Jens

    ![Gateway Error.png](/public/imported_attachments/1/Gateway Error.png)
    ![Gateway Error.png_thumb](/public/imported_attachments/1/Gateway Error.png_thumb)



  • I think you need to leave the Interface IPv4 and IPv6 both set to none, and OpenVPN looks after that underneath.


  • LAYER 8 Netgate

    Yes, all of the instructions for assigning an interface to an OpenVPN instance just tell you to enable it and optionally name it and set nothing else then bounce the OpenVPN process.



  • Hi all,

    thank you very much for the responses. Restarting the OpenVPN connection was the bit I was missing.

    Regards,

    Jens


Log in to reply