D-Link DWR-921 3g/4g modem in transparant bridge not working on WAN pfSense DHCP



  • We are trying to get the D-Link DWR-921 to work with pfSense. The modem is set to transparent bridge. If the modem is connected to the pfSense there is no traffic.  If we connect it to a Windows 7 machine or a Raspberry Pi it works immediately.

    The block private networks option is turned off.

    Could this be something in the DHCP request???? Strange thing is it uses its own ip address as gateway address.


  • Banned

    The transparent bridge is not transparent enough and is way too wet.  ::) ::) ::)



  • It works on a Windows 7 machine and a Raspberry Pi. Why not on pfSense. Do i need to use adjust some none standard settings?



  • @BCSE:

    Could this be something in the DHCP request???? Strange thing is it uses its own ip address as gateway address.

    To verify your connection, set it WAN to static and enter an unused IP and valid gateway.



  • It's a 3g/4g mobile broadband internet connection. I am not able to set an static ip other then the one that is given bij DHCP. Reconnecting changes the ip address.

    The connection is ok on a Windows 7 machine and a Raspberry Pi so it could work but not on pfSense for now.



  • So the modem will provide external ip, gateway and dns by dhcp. It does this correctly with a lan to lan interface of win7 and Pi as dhcp clients.

    Transparent bridge mode is configured by checking Disable NAT for 3g/4g connection and unchecking Enable DHCP Server.

    Wan port of dwr-921 is not connected. Only pfsense wan is wired to dwr-921 lan ports. Yes?



  • So the modem will provide external ip, gateway and dns by dhcp. It does this correctly with a lan to lan interface of win7 and Pi as dhcp clients. Yes. Just tried it on a MacBook Air. Also works immediately. IP-address and gateway address on MacBook are also the same.

    Transparent bridge mode is configured by checking Disable NAT for 3g/4g connection and unchecking Enable DHCP Server. See printscreen. There is an option 'Transparent Bridge'. Nat disable doesn't give me an ip address

    Wan port of dwr-921 is not connected. Only pfsense wan is wired to dwr-921 lan ports. Yes? Yes

    I tried a ping on pfSense from the WAN address to 8.8.8.8 but this gives me 100% packet loss.



  • Sorry if I am not helping, but I do not have a dwr-921 to test with. The manual that I have does not document a transparent bridge setting.

    Have you tried setting the dwr-921 with transparent bridge unchecked?

    Have you tried setting the dwr-921 with transparent bridge unchecked and disable NAT checked?



  • I have the same manual  :)

    Both settings are not giving the pfSense a ip address. I don't think it's the modem. I think the pfSense needs some other settings. Because all other devices do work.



  • Just to verify that there isn't something funky in the setup, could you post a screen shot of "Interfaces->WAN" from your pfSense box?

    You didn't mention what hardware you're running on, perhaps there's an oddity with the type of NIC you're using in pfSense.

    You might try swapping the assignments for LAN and WAN to see if a different NIC type has a better chance of negotiating DHCP.

    One last thought, have you power cycled the DWR-921 between different attempts?
    I have seen an issue on some DSL modems where they maintain previous MAC addresses used and won't hand out anything new until they have been rebooted.



  • The hardware is PC Engines Alix.2D13 on pfSense 2.1.5. Also tried the Alix.APU1D4 on 2.2.1 with no luck. These were new installs of pfSense.

    I didn't try different NIC's because they are all the same and i tried the APU.1D4 which has newer NIC's.

    Yes, i power cycled. But that didn't help.

    I tried disabling packet filtering. At that moment i was able to ping from the WAN interface. At LAN still no traffic. Firewall rules are standard rules.



  • Anyone??



  • Same problem here, i get the external IP on the pfsense WAN but it can´t do the routing between the LAN and the WAN.



  • It´s a firewall problem on the pfsense , just add a floating rule on the WAN to allow all trafic and it start to working .



  • Thanks Telmocalhaco!! That seems to work. I'm not familiar with floating rules so i need to figure out what i'm doing exactly.



  • This sounds like some funky forced promiscuous mode

    http://en.wikipedia.org/wiki/Promiscuous_mode

    Like the IP address set is the gateway, like you're supposed to send all packets out, no real gateway specified. I assume it's so that a cell tower can respond, no matter the IP address it happens to have.  This is how amazon handles its instances behind a transparent nat.



  • Did anyone resolve this issue? i have a DWR-921 too with DG issue in transparent brigde mode.  How did you get the DG to be picked up with DHCP?



  • See telmocalhaco's answer. This solved the problem for me at the time.

    Although the setup was not stable for a us. Connection was failing a lot. Had to reconnect to 4G to get it al back working again.

    The modem isn't in transparant mode anymore. pfSense is getting a 192.168.x.x ip address from the D-Link now and this setup is stable now for a few months. The 4G connection is just an internet connection no NAT ar anything so the solution is acceptable for us.

    If you figured out to get the connection working & stable i would like to here it.



  • @telmocalhaco:

    It´s a firewall problem on the pfsense , just add a floating rule on the WAN to allow all trafic and it start to working .

    hi i have the same scenario how did you make the floating rule I can’t seem to get it to work
    I have 2 wan a dsl and now I use d-link as a backup 4g wan

    I get an external ip address on the port but can’t route traffic and it show the gateway as offline
    please help I have a bad internet I have the latest pfsense