PfSense Issues on Comcast Internet



  • So.. I Have 2.1 running on a Dell Poweredge 860 Server. (2.2 Just will not play nice for me) Using Intel Server Nics, 8 Gigs of Ram. Worked perfectly on my old ISP. I moved a month and a half ago and now I have Comcast. (My area only uses Comcast). New SB6121 modem and same config except for now using the IPV6 option also… If I restart the modem and pfsense I get the bandwidth I pay for 25 down 5 up... After an hour or two with no one using the internet the bandwidth goes to a crawl 3 to 4.5 down and the up always stays at 5.. I have been round and round with Comcast Techs and I have tried everything from swapping out ethernet cables to new NIC's to moving my WAP away from the modem and pfsense router.. Nothing in the System logs. Modem config page logs shows some weird so called "Event" on July 1, 1977.. (Yes...it says 1977) Anyone run into this king of issue with pfsense and Comcast ?



  • have you browsed to the modem and checked the number of channels bonded, errors (recoverable and unrecoverable)?  Has Comcast pushed new firmware to the modem?  They've gotten stuff wrong once in a while.  Sounds like old ISP was not using the "…new SB6121..."  (is that from them or did you buy it?)  That looks like it'll bond 4 up and 4 down;  if errors are happening you lose the bonding so you lose bandwidth.  I opted for the Zoom instead a while ago (8 down 4 up).  On the Zooms, if you press and hold the reset button until it starts to reboot, it gets config and other info from the provider again (channels to use, bonding, etc).  Maybe something similar on the SB6121?



  • that sounds like a bad signal to the modem

    check up and downstream of the modem and SNR lefels everything from -30 to -40 on the SNR is ok

    also check corrected and uncorrected errors

    with comcast the signal levels for up and down should be -5 to +5 on the downstream and -40 to -48 on upstream



  • Have you tried by-passing PFSense to see if the problem continues?


Log in to reply