Dhcpleases: Could not deliver signal HUP to process because its pidfile does …



  • 2.2.2-RELEASE  (amd64)
    built on Mon Apr 13 20:10:22 CDT 2015

    After reboot I'm seeing this in my system log:

    Apr 15 23:17:44 dhcpleases: Could not deliver signal HUP to process because its pidfile (/var/run/dnsmasq.pid) does not exist, No such file or directory. 
    Apr 15 23:17:44 dhcpleases: Could not deliver signal HUP to process because its pidfile (/var/run/dnsmasq.pid) does not exist, No such file or directory. 
    
    

    What's wrong?

    esquire1986



  • Probably just cosmetic. Is Services>DNS Forwarder enabled? Looks like it thinks it should be, but isn't running.



  • DNS-Forwarder is enabled with this settings:

    Enable DNS forwarder … checked
    Register DHCP leases in DNS forwarder ... checked
    Register DHCP static mappings in DNS forwarder ... checked

    all other points are unchecked

    Interfaces: LAN, OPT2, Localhost

    Advanced: local=/firewall.lan/ … it's my domain

    no overrides

    Is there a misstake?



  • Does it show as running under Status>Services?

    What do you have that local= advanced line there for? Wondering if that line's syntax is invalid maybe and that's preventing it from starting. Though you shouldn't be able to save anything syntactically incorrect under Services>DNS Forwarder as it checks with dnsmasq to validate the config there as input validation.



  • Sercice/Status: dnsmasq is running

    I tried to change the advanced setting to …

    local=/firewall.lan ... not accepted
    local=firewall.lan/ ... not accepted
    local=firewall.lan ... not accepted

    ... only ...

    local=firewall.lan ... works. So the syntax must be right.



  • As long as the service is running, that config's fine.

    That error happens during boot because the DHCP lease registration process wants to HUP dnsmasq upon certain changes, but at that time during boot it may not be running. It's safe to ignore.


Log in to reply