Manutenção das conexões estabelecidas - Regras



  • Caros, boa noite.

    Sou novato com Pfsense, e estou com a seguinte dificuldade. A empresa possui 02 predios (2 quadras de distancia) para estabelecer conexão entre os predios temos uma conexão radio (antena), onde no predio filial a antena esta conecta ao switch e na matriz esse link da antena esta conectada a um servidor firewall debian (iptables) na interface eth3 (192.168.36.1), na matriz a rede é 192.168.5.0/24 e na filial é 192.168.36.0/24, no firewall da matriz o ip forward esta ativo para que tenhamos o roteamento e as redes possam se enxergar. Todo o trafego de rede (internet, servidores, etc..) da filial vem atraves da antena e utiliza a estrutura da matriz, a diretoria deciciu isolar esse trafego limitando somente a alguns serviços, ou seja, estou colocando um servidor com Pfsense na filial e configurei já o DHCP e Squid + SquidGuard, essa parte esta OK.

    As estações estão recebendo os IP´s definidos por Mac Address e estão navegando pelo link novo da filial de acordo com as regras do Squid que adotei. Porem utilizaremos ainda como disse alguns serviços da Matrix, como por exemplo o comunicador Openfire, Autenticação no AD, Compartilhamento de arquivos via Samba e no próprio Windows.

    Para isso adicionei um novo gateway como 192.168.36.1 e adicionei uma rota nova, da forma que tudo que tiver como destino 192.168.5.0/24 utilize o GW 192.168.36.1, e liberei nas regras de firewall tudo que tiver origem Lan Net para Network 192.168.5.0/24 utilizando o gw 192.168.36.1, e tb tudo que tiver origem em 192.168.5.0/24 para Lan Net utilizando o mesmo gw.

    Consegui efetuar ping de ambos os lados, de 36.0 para 5.0 e vice-versa.

    Mas o Spark que utilizo para comunicar com o Openfire (192.168.5.9 na porta 5222) estabelece a conexão mas depois de algum tempo cai, e fica oscilando.

    Como posso resolver esse problema? Acredito que tenha que manter as conexões estabelecidas mas como faço isso no Pfsense.

    Se é que é esse o problema!

    Se puderem me ajudar fico muito agradecido.

    []s

    Wagner



  • boa noite estou passando por um problema similiar, mas atualmente nos temos duas subnets na mesma rede fisica ou seja temos duas, porem elas nao estao separadas por vlans, somente pelos ips mesmo. Meu pfsense tem duas placas de rede uma de cada rede, e temos servicos que rodan exclusivamente em uma rede e por algum motivo as estacoes estao tendo que ter ip nas duas redes para poderem se comunicar. Uma coisa bem boa que fica acontecendo eu estando em uma rede e acessar um TS da outra rede a conexao fica caindo como se estivesse me desconectando.

    Como resolveu essa questao sua?