Troco o IP da WAN e não navega mais


  • Pessoal faz tempo vem acontecendo este mesmo problema comigo e nunca sei o motivo e nem como resolver. Pode até ser um problema bobo, mas como estou iniciando no mundo PfSense venho pedir a ajuda de vcs, que possivelmente já tenha visto isso:

    Tenho um servidor PfSense 2.2.1(mas já ocorreu na versão 2.0 e 2.1 tbm) onde tenho uma interface de rede WAN com o IP 192.168.254.10 e gateway 192.168.254.1
    e outra interface LAN com o IP 192.168.1.1. Este PfSense é um proxy de rede configurado o squid e squidguard. Bem até ai tudo funcionando ok.

    Só que as vezes este link da minha WAN cai, ai como tenho o link secundário de outro provedor eu vou e substituo os IPS da WAN para 192.168.253.10 e gateway 192.168.253.1 para sair para internet por outro provedor certo? Eu entendo que a lógica seria esta, porém quando faço esta alteração os PCs clientes deste proxy para de navegar na internet. Simplesmente não funciona. Vale ressaltar que o link secundario esta funcionando, pois utilizo ele em outros proxys.

    Sempre que configuro o link na instalação funciona mas se eu precisar trocar não funciona mais.

    Alguém pode me dar uma luz para este problema?


  • Resolvi o problema excluindo todos os gateways cadastrados e criando-os novamente.

    Vlws …


  • pedrootero Faz LoadBalance para não ficar trocando o IP sempre que isso acontece, pode te ajudar. Vai precisar de duas interfaces WAN.

    https://doc.pfsense.org/index.php/Multi-WAN

    Youtube Video


  • @avner_ads:

    pedrootero Faz LoadBalance para não ficar trocando o IP sempre que isso acontece, pode te ajudar. Vai precisar de duas interfaces WAN.

    https://doc.pfsense.org/index.php/Multi-WAN

    Youtube Video

    Muito bom cara, obrigado pela força ai…

    Estou com um probleminha na minha rede, assim que resolver vou testar a configuração e dou o feedback.


  • Cara fiz o teste com FailOver funcionou certinho porém o proxy squid não funciona quando o link 1 cai e o link 2 assume.

    Tem alguma solução para isso?


  • bom dia

    experimente 2 coisas

    use a opção

    tcp outgoing address 127.0.0.1

    no campo Custom Options na guia General do seu proxy server

    e em muitos casos, marque a opção loopback em Proxy Interface