Squid + SquidGuard + ad, não funciona no win2012



  • Pessoal,  Bom dia !!!!

    Eu tinha o Squid + SquidGuard configurado para que o Group ACL do SquidGuard checasse as regras no AD, ele estava configurado para Windows 2008 PORTUGUÊS, mais ontem migramos para o windows 2012 Ingles, e essas regras pararam de funcionar.

    ldapusersearch  ldap://172.18.150.50:3268/cn=AcessoRestrito,OU=Internet,OU=stampline,DC=stampline?memberUid?sub?(&(objectclass=posixGroup)(memberUid=%s))

    Quando o Squid pede a senha de autenticação no Browser, ele consegue autenticar normalmente.,.. somente quando o SquidGuard vai checar o grupo do usuario, por alguma motivo ele nao consegue acessar o AD que esta no novo Windows.

    Ja chequei…

    • Estrutura o cn, ou e
    • Usuário e senha
      -Telnet na porta 3268

    Mais nao vi nada de errado....

    Alguem poderia me dar alguma dica... do que possa estar acontecendo... tem alguma incompatibilidade Win 2008 Portugues x Win 2012 Ingles x Ldap ??



  • Cara, isso é alguma mudança relacionado à consulta Ldap do 2012.

    pra falar a Verdade nunca perdi muito tempo com Ldap no 2012 por falta de tempo hábil, então configuro via Radius (Mas não faço consulta por grupos no AD via LdapSearch como vc sugere)



  • estranho, porque ele loga usando o ldap, so nao funciona usando o ldapusersearch



  • Olha, não sei se tem haver.

    no exemplo que vc deu, está usando a porta do GC, já tentou colocar a porta 389 do ldap?



  • sim, ja tentei e nao funcionou tb… :)



  • @marcosgpm:

    sim, ja tentei e nao funcionou tb… :)

    Vish

    Talvez nesse feriado eu consiga montar um Lab com esse LdapSearch


Log in to reply