[solved] Alix new install boot problem / serial console outputs garbage



  • Hi all,

    I am unable to boot pfSense on my Alix 2d13 using a compact flash card.

    • used to work flawlessly with pfSense 2.2 on a 4GB CF card
    • tried pfSense 2.2.1 and 2.2.2, embedded version of both 4g and 2g, i386
    • tried on a brand new 16GB CF card, same problem
    • tried other baud numbers for the serial console, 115200, 38400

    I copy the img file on the card using dd bs=16k.

    Most times I get a flashing pattern of the 3 LEDs after about one minute:
    1, 1  2, 2  3, 3 then again 1, 1  2, 2  3, 3 and so on.
    (1, 1 being a double blink of the left LED, 2, is the middle LED and 3 is the right LED)

    BIOS version is 0.99h, so should be ok.

    Console output, using the command gtkterm -p /dev/ttyUSB0 -w Xon -s 9600,
    gives only garbage after the boot screen:

    1  pfSense
    2  pfSense
    
    F6 PXE
    Boot:  1
    

    I have been at this for hours with no luck..could somebody please help me out?



  • New versions default to 115200 on the serial console, so try starting with your term set at that. BIOS output will be garbage, either change the BIOS speed, or change console when it boots. You need to have the serial up to assign interfaces, as vr is no longer the default.



  • @dotdash:

    New versions default to 115200 on the serial console

    I tried 115200, but got no readable output.
    Will try 115200 again right from the boot-up..although I don't think that should be an issue. I tried several speeds while booting, none was readable.



  • Having the console at baud 115200 from the very start did the trick..many thanks for your quick answer.

    It's a pity switching speeds while booting does not work.



  • @dotdash:

    New versions default to 115200 on the serial console

    i doubt the default speed in freebsd is 115200, atleast it doesnt seem so on my alix


  • Banned

    @xbipin:

    @dotdash:

    New versions default to 115200 on the serial console

    i doubt the default speed in freebsd is 115200, atleast it doesnt seem so on my alix

    https://doc.pfsense.org/index.php/2.2_New_Features_and_Changes#OS_Changes


Log in to reply