MultiWan Dns Problem when link1 goes down



  • Dear Guys

    I have a problem with DNS over a multiwan (failover) configuration…. the problem happens when the link1 goes down... all workstation and include the pfsense mashine stopped to resolve names... everybody can ping IP but can't ping names... here is my configurations:

    LAN - 192.168.1.2
    WAN1 - 192.168.200.101 -> GW 192.168.200.100
    WAN2 - 192.168.201.101 -> GW 192.168.201.101

    General Setup:
    Dns1 - 8.8.8.8 - using the gateway Wan1GW
    Dns2 - 8.4.4.4 - using the gateway Wan2GW

    On the firewall rules, i have a fullpass over the lan configuration... normally

    My route table with both links working:
    default 192.168.201.100
    8.8.4.4 192.168.200.100
    8.8.8.8 192.168.201.100

    On the gateway groups i'm monitoring 8.8.8.8 for wan and 8.8.4.4 for wan2

    Block private networks - Unchecked for both wans
    Block bogon networks - Unchecked for both wans

    I'm running pfsense 2.2.2

    Maybe someone can help me , please?

    Thank you ,



  • Dns2 - 8.4.4.4 - using the gateway Wan2GW

    I guess that is just a typo in your post - should be 8.8.4.4

    Which DNS are you using - Forwarder (dnsmasq) or Resolver (unbound)?
    If Resolver, is forwarding mode enabled or not?



  • sorry, I typed wrong here … in pfSense I use 8.8.4.4 ...

    I've tried both (dnsmasq/unbound) and unfortunately it did not work .. when I used the resolver I've enabled 'forward mode' normally

    This error is very strange and is driving me crazy

    thanks



  • After much suffering… the problem was solved:

    1- request to providers to send me a public network "/30" instead of a private network;

    2- I changed all workstations to get IP over DHCP (pfsense server). I had set fixed IP for each workstation;

    Problem solved, failover working fine ...


Log in to reply