Upgrade from 2.1.5 to 2.2.2 - wrong 'bitness'



  • Hi folks,

    I just did an automatic upgrade from 2.1.5 to 2.2.2 via the GUI.  The upgrade seemed to have gone fine until the reboot.  The system never initiated the reboot, I had to power it down.  Upon reboot, my box came up and the web GUI was working.  The console would not come up (the menu).  System logs showed wrong owner/permissions on several key files (/etc/login.conf, tons of pam stuff as well).  I fixed those manually using the GUI command prompt option.  Then the menu came up and I was able to get a shell.

    Then I noticed that most of my packages didn't start, including TinyDNS.  TinyDNS pointed me to svscan not running.  I tried to start the process normally but it complained with 'Exec format error. Binary file not executable.' I looked at /usr/local/bin and noticed that many of the symlinks there were pointing to /usr/pbi/djbdns-amd64/bin/.  This confused me since uname -m clearly shows my distro to be i386.  I manually replaced the symlinks for the svc supervisor files (pointing at the i386 dir) and was able to get it started.  TinyDNS still won't start however, even after package re-installation.  The same goes for sshd.  Weirdly enough, the fw still works, so does Snort (after re-installation), and a few other packages.  I appear to have a semi-working installation.

    I did convert my hdd to labels (fstab).  I also ran fsck on boot to make sure the disk was fine.  Signs point to something getting confused regarding the 'bitness' of my system.  Is there a way to fix this?  Or is this a re-install?  I also noticed that I have a ton of files owned by uid 1001 and gid 1001 (which don't exist.)  I don't know if that's new, or if it is intentional.  I have never had an issue like this with a pfsense upgrade.

    Thanks in advance for any suggestions!


  • Banned

    Considering that you accidentally swapped arch (braindead GUI plus no check/prompt on trying to do so), plus suffered the infamous fsck filesystem corruption bug killing /etc files, yeah, do a full reinstall. After than, restore the config, and in System - Firmware - Updater Settings - Firmware Branch select the proper arch from the dropdown and save it.



  • Thank you much.  I did a full reinstall and recovered my config file.  Things seem to be working mostly.  I have two issues, both with packages:

    • tiny-dns server just won't start. I have tried ti uninstall and reinstall the package several times.  It relies on the svscan daemon which seems to be absent from my system.  My guess is that this package is no longer compatible with 2.2.  Any replacement option for a small DNS server?

    • arpwatch is in the same boat as tiny-dns.  It just won't start and won't log anywhere.  I have also reinstalled it several times.

    Any suggestions are much appreciated!


  • Banned

    tiny-dns - never used it, never will use it. DJBware -> yuck! What's your need for the package? Use bind if you need an authoritative DNS server. The package looks exactly as dead in pfSense as it looks upstream. DNS is an evolving thing. Using 2001 code does not seem like a viable option.



  • Ah, I didn't know BIND was a package now.  Got rid of that tiny-dns thing and installed BIND.  Looking good and I actually have the features I wanted.  :D

    Still no go on the arpwatch front, but whatevs.  I will deal with it.  Thanks for all the help!


Log in to reply